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Overview

This section discusses the following topics:
• Comtrol Drivers Management Console
• Supported Operating Systems
• Products Supported
• Conventions on Page 6
• Downloading the Latest Software and User Guides on Page 6

Comtrol Drivers Management Console

This User Guide discusses how to install and configure Comtrol device drivers 
using the Installation Setup Wizard and the Comtrol Drivers Management Console 
for the device driver.
The Comtrol Drivers Management Console is accessible through the Windows 
Control Panel using a dedicated shortcut created during the initial device driver 
installation process. The Comtrol Drivers Management Console allows you to 
browse all installed and supported Comtrol products in one place and apply any 
changes quickly.
Note: This User Guide discusses Comtrol adapters, see the DeviceMaster Device 

Driver User Guide for Windows for DeviceMaster specific information.
You can refer to Using the Comtrol Drivers Management Console on Page 19 for 
general information about the Comtrol Drivers Management Console.

Supported Operating Systems

The Comtrol Drivers Management Console supports the following operating 
systems:
• Windows 10, Windows 8.1, Windows 8, and Windows 7
• Windows Server 2016 and Windows Server 2012R2
Note: You can refer to downloads.comtrol.com for older operating system support.

Products Supported

These are the products supported by the Comtrol Drivers Management Console:
• DeviceMaster LT
• DeviceMaster PRO, DeviceMaster RTS, and DeviceMaster Serial Hub
• RocketPort EXPRESS
• RocketPort EXPRESS SMPTE
• RocketPort INFINITY
RocketPort INFINITY/EXPRESS Driver User Guide: 2000634 Rev. A Overview - 5
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 Overview 
Conventions

In the remainder of this User Guide, the products are referred to accordingly:
• Comtrol device unless there is model-specific information
• DeviceMaster means the DeviceMaster models listed in the previous 

subsection
• RocketPort means any RocketPort model
• RocketPort EXPRESS/INFINITY means RocketPort EXPRESS, RocketPort 

EXPRESS SMPTE, and RocketPort INFINITY

Downloading the Latest Software and User Guides

You can use the following table to locate the latest version of the software and 
documentation.

Software or Document Description

Device Driver The device driver supports Windows operating 
systems. as discussed in Supported Operating 
Systems on Page 5.

User Guide for Windows
(this Guide) This User Guide supports all Comtrol adapters in 

the Comtrol Drivers Management Console.

Bootable Diagnostics You can download and create a bootable Diagnostics 
CD.

Comtrol Utility You can use the Comtrol Utility to test or monitor 
ports. The Comtrol Utility includes Test Terminal 
and Port Monitor.

RocketPort EXPRESS 
User Guide This User Guide provides adapter and interface 

installation procedures. It also provides information 
about connecting serial devices.

RocketPort EXPRESS 
SMPTE User Guide This User Guide provides adapter and interface 

installation procedures. It also provides information 
about connecting serial devices.

RocketPort INFINITY 
User Guide This User Guide provides adapter and interface 

installation procedures. It also provides information 
about connecting serial devices.
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Device Driver Installation

This section discusses the following topics:
• Overview of the driver installation procedures
• Installation Setup Wizard on Page 7 for initial installation procedures
• Checking the Device Driver Version on Page 13
• Updating the Driver on Page 14
• Adding an Adapter (Existing Installation) on Page 18

Overview

If there is a device driver already installed on your system for the RocketPort, see 
Updating the Driver on Page 14 or Adding an Adapter (Existing Installation) on 
Page 18.

Installation Setup Wizard

You can use the following procedure to install the device driver and the Comtrol 
Drivers Management Console, which is used to configure the driver.
1. Locate the latest driver assembly (.exe) for your product and copy it to a 

location that is available to the host.
Note: Administrative privileges are required to install device drivers on 

Windows operating systems.

2. Close any applications that are using serial ports before the device driver 
installation.

3. Install the adapter and connect the interface (Quadcable, Octacable, or 
interface box). If you need hardware installation procedures, see Downloading 
the Latest Software and User Guides on Page 6) to locate the User Guide for 
your adapter type. 
Do not connect RS-422/485 devices until the appropriate port interface 
type has been configured in the device driver. The RocketPort default 
port setting is RS-232, except for SMPTE models, which are set to RS-
422. Caution
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 Device Driver Installation 
4. Click Cancel if a Found New Hardware message appears.

5. Start the installation by executing the .exe file for your adapter.
Driver assembly file names include the driver version number. 
For example, RP_EXPRESS_INFINITY_Windows_x.xx.exe, where x.xx is the 
driver assembly version.

6. Click the Yes button to the Do you want to allow this app to make changes to 
your device message.

7. Click Next to start the installation process.
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8. Optionally, enter a different location to install the driver files.

9. Click Install.
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 Device Driver Installation 
10. Leave the Launch RocketPort EXPRESS/INFINITY Driver Installation box 
checked and click Finish.

If you do not check this box, you can use the shortcut under the Start button at 
the location for your adapter type to start the driver installation: Comtrol> RP 
EXPRESS INFINITY Driver Installation Wizard

11. Click Next to install the driver.
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 Device Driver Installation 
12. Click Install and Next. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

13. Click Next.

14. Click Proceed.
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You may see this popup for each device.

15. Click the Launch Comtrol Drivers Management Console button.

16. Return to the Installation wizard and click Close to exit the wizard.

17. Go to Configuring COM Port Properties on Page 27 to configure the COM port 
properties for RocketPort adapters 

18. If desired, go to Configuring Device Properties on Page 25 to set up advanced 
device properties (device name and starting COM port number).

After driver installation and configuration, connect the serial devices to the ports. 
For information about the RocketPort connectors, refer to the appropriate User 
Guide (Page 6).
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Checking the Device Driver Version

You can check the driver version using the following procedure.
1. In the Comtrol Drivers Management Console, right-click the Comtrol device and 

click Properties.
2. If necessary, click the Driver tab to view the device driver version.

Note: Please note that Microsoft truncates leading zeros in the versions 
number. The above driver version is 5.06.

If necessary, you can update the device driver using the next subsection.
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Updating the Driver

Use the following procedure to update the RocketPort device driver after initial 
installation.
If you are unsure what driver version is running, see Checking the Device Driver 
Version on Page 13.
1. Locate the latest device driver assembly (Page 6) and copy it to a location that 

is available to the host.
2. Close any applications that are using serial ports before the device driver 

installation.
3. Start the update by executing the .exe file.
4. Click Next to start the Installation Setup Wizard.

5. Optionally, enter a different location to install the latest device driver files.
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6. Click Install.

7. Leave the Launch RocketPort EXPRESS/INFINITY Driver Installation box 
checked and click Finish.

If you do not check this box, you can use the shortcut under the Start button at 
the location for your adapter type: Comtrol> RP EXPRESS INFINITY Driver 
Installation Wizard.
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8. Click Next to update the driver.

9. Click Update and Next.

10. Click Next to update the driver.
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11. Click Proceed.

12. Click the Launch Comtrol Drivers Management Console button to configure the 
ports or device properties.

13. Return to the Installation wizard and click Close.

14. If necessary, go to Configuring COM Port Properties on Page 27 to configure 
the COM port properties for RocketPort adapters.

15. If desired, go to Configuring Device Properties on Page 25 to set up advanced 
device properties (device name and starting COM port number).
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Adding an Adapter (Existing Installation)

Use the following procedure to add an adapter to an existing RocketPort 
installation.
1. Close any applications that are using serial ports before the device driver 

installation.
2. Install the adapter and connect the interface (Quadcable, Octacable, or 

interface box).
If you need hardware installation procedures, see Downloading the Latest 
Software and User Guides on Page 6). 
Do not connect RS-422/485 devices until the appropriate port interface 
type has been configured in the device driver. The default port setting 
is RS-232.

3. Click Cancel if a Found New Hardware message appears.
4. From the Start button, click: Comtrol> RP EXPRESS INFINITY Driver 

Installation Wizard. 

5. Click Next to start the 
Comtrol Driver 
Installation Wizard. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. Click Install and Next.

7. Click Next and follow the Installation Wizard. Refer to Step 12 on Page 11, for 
the remainder of the installation steps if needed.

Caution
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Device Driver Configuration

This section discusses the following topics:
• Using the Comtrol Drivers Management Console on Page 19
• Configuring Device Properties on Page 25
• Configuring COM Port Properties on Page 27

Using the Comtrol Drivers Management Console

This subsection discusses basic Comtrol Drivers Management Console operations, 
such as:
• Accessing the Comtrol Drivers Management Console
• Displaying All Installed Devices on Page 20
• Collapsing the View on Page 21
• How to Configure Device Properties on Page 21
• Customizing the Device Name on Page 22
• Customizing the COM Port Name on Page 22
• How to Configure COM Port Properties on Page 23
• How to Save Changes on Page 24
See Configuring Device Properties on Page 25 to start configuration procedures for 
your adapter.

Accessing the 
Comtrol Drivers 
Management 
Console

Accessing the Comtrol Drivers Management Console can be done using one of the 
following methods:
• Windows Control Panel; go to your Control Panel and click on the Comtrol 

Drivers Management Console.
•  Shortcut; located under Start > Comtrol >  RP EXPRESS INFINITY Driver 

Management Console.
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Displaying All 
Installed Devices

The Comtrol Drivers Management Console opens and displays all products for 
which a device driver was installed. 
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Collapsing the View To collapse the view, click - in the Tree View pane to close the selected family. To 
view a family or device, click the + to open the selected family. 

How to Configure 
Device Properties

This overview discusses changing device properties for a product. Highlight the 
device name of the product that you want to configure in the Tree View pane. Make 
any necessary changes.
• Click Apply to save the changes, which saves the changes and leaves the 

Comtrol Drivers Management Console open.
• Click Ok to save the changes and close the Comtrol Drivers Management 

Console.
• Click Cancel to close the Comtrol Drivers Management Console without saving 

the changes.
If you click a port or device name without saving the changes, the Comtrol Drivers 
Management Console prompts you to Apply, Ignore, or Cancel the changes.
For more information, see Configuring Device Properties on Page 25. 
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Customizing the 
Device Name

Change the default Device Name on the Device General tab by changing the name 
in the User-Friendly Device Name field and saving the change.

Customizing the 
COM Port Name

Change the default Port Name on the Port Settings General tab by changing the 
name in the User-Friendly Port Name field and saving the change.
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How to Configure 
COM Port 
Properties

To change a port’s properties for a product, highlight the port of the product that 
you want to configure in the Tree View pane. Make any necessary changes:
• Click Apply to save the changes, which saves the changes and leaves the 

Comtrol Drivers Management Console open.
• Click Ok to save the changes and close the Comtrol Drivers Management 

Console.
• Click Cancel to undo the changes and close the Comtrol Drivers Management 

Console.
If you click another port or device name without saving the changes, the Comtrol 
Drivers Management Console will prompt you to Apply, Ignore, or Cancel the 
changes.
For more information, see Configuring COM Port Properties on Page 27.
After saving the port changes, if desired, you can click Apply These Settings to All 
Ports to populate the remaining ports with these COM properties. 
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How to Save 
Changes

The Comtrol Drivers Management Console indicates that changes have been made 
on this screen with a red frame that identifies which device’s General tab you are 
editing.
• Clicking the Apply button saves the changes on the tab and leaves the Comtrol 

Drivers Management Console open for further configuration.
• Clicking the Ok button saves the changes on that tab and closes the Comtrol 

Drivers Management Console.
• Clicking the Cancel button cancels the changes on that tab and closes the 

Comtrol Drivers Management Console. 
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Configuring Device Properties

Use the following procedure to change device settings on an adapter 
1. Open Comtrol Drivers Management Console (Accessing the Comtrol Drivers 

Management Console on Page 19).
2. Highlight the adapter device name that you want to configure.

3. If desired, change the User-Friendly Device Name.
4. If desired, set a Starting COM Port number value.
5. Optionally, click Verbose Event Log if you want to log additional RocketPort 

information into the event log.
6. Select the Driver’s Working Mode.
7. Optionally, select a different Scan Rate (ms) (Page 26).
8. After making your changes, click Apply if you have additional configuration 

procedures or click Ok if you have completed configuring your Comtrol devices.
Note: If you do not Apply the changes, you will be prompted to Apply, Ignore, or 

Cancel the changes.
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The following table provides detailed information about Device General tab options 
for the RocketPort.

Device General Tab Description

Device Name
This is the default name assigned by the driver and it cannot be 
changed. You can use the User-Friendly Device Name field to provide 
custom device names for your installation.

User-Friendly Device Name Use this field to enter a more descriptive name. The name that you 
assign is not saved until you click Apply or OK.

Starting COM Port Number

You can change the starting COM port number in the drop list for 
this adapter.
In addition, you can use Starting COM Port to set nonsequential 
starting COM port numbers for each adapter, thus leaving gaps in 
the COM port numbering sequence.
When you change the starting COM port number, the driver assigns 
that COM port to the first port on this adapter and all other port 
numbers follow in sequence.
Do not overlap COM port numbers between devices or other 
adapters because if you do so, the overlapping ports are disabled.

Verbose Event Log

Default = Disabled

Selecting this option causes detailed messages to be sent to the 
operating system Event Log. This added information can be useful 
when debugging communications and configuration problems

Driver’s Working Mode

Select the mode that meets your application requirements.
Polling (default)
• Smaller packets
• Lower volume
• Faster I/O (Low Latency)
• Predictability (Based on Scan rate)
• Perfect for low baud rates or low volume transfer where the 

operation is time critical.
Interrupts

• Larger packets
• Higher volume
• The speed of I/O depends on the volume of data 
• Unpredictable
• Perfect for high baud rate, high volume data transfer.

Scan Rate (ms)]

Default = 10ms

Typically, you should leave the scan rate set to the default value (10 
ms) for most applications. To adjust latency for time-critical 
applications, select a longer or shorter interval from the droplist, or 
type in the rate (2 to 50). If a value larger than 50 is entered, the 
maximum of 50 is implemented. 
Note: The faster the scan rate (lower number), the higher the load 

on the system processor.

Save Configuration
Click Save Configuration to save the Device Settings for use on 
another similar Comtrol device or to archive a copy of your 
environments settings.

Load Configuration

Click to Load Configuration to load the Device Settings previously 
saved using the Save Configuration feature.
Note: You cannot a load configuration file from different models. 

For example, you cannot load a configuration file for a 
RocketPort INFINITY on a RocketPort EXPRESS.
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Configuring COM Port Properties

This section discusses COM port configuration procedures for RocketPort ports. If 
you want to change the starting COM port number on the RocketPort, see 
Configuring Device Properties on Page 25.
If your application does not set COM port properties, use the Device Manager to 
access Ports (COM & LPT) to change the port parameters. If the application sets 
COM port properties, those settings take precedence over Windows COM port 
settings. The exception to this guideline is if you use the Override and Lock Baud 
Rate to option.
Use the following procedure to change COM port settings on a RocketPort port or 
ports.

Do not connect RS-422/485 devices until the appropriate port interface 
type has been configured in the driver. The driver default port setting 
is RS-232.

1. Open Comtrol Drivers Management Console (Page 19).
2. Highlight the appropriate RocketPort.
3. Highlight the first port you want to configure.
4. Select the appropriate communications mode.

5. Enable the features that you require for your environment.
Note: You can use the help system or refer to the following table for 

Ok Click Ok to save the changes made on this page and close the 
Comtrol Drivers Management Console.

Cancel Cancels any changes made on this page.

Apply
Click Apply to save the settings on this page. If you do not click 
Apply before leaving this page, you will be prompted to Apply or 
Cancel the changes.

Device General Tab Description

Caution
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information about each option.
6. Select the Use Fast (Low Latency) Data Transfer option when receiving or 

sending small blocks of data.
7. Optionally, click the RTS Toggle Options button:

• If your communications application does not toggle FTS when transmitting 
in RS-485 mode.

• If you are using an 
external RS-232 to 
RS-485 converter, 
which is attached to 
a port that is 
configured for RS-
232. 

a. Click the 
appropriate options 
for your 
environment.

b. Click OK to save 
the changes and 
return to the port 
General tab.

8. If desired, click the Clone check box to set all of the ports on this Comtrol 
device to these characteristics.

9. Optionally, change the User-Friendly Port Name.
10. If desired, select a different COM Name (COM port number). The drop-down 

list displays (in use) next to COM port numbers that are already in use in this 
system. Do not duplicate COM port numbers as this will cause the ports to not 
function.

11. Click Apply to save these changes.
Note: If you selected RS-422 mode, make sure that there is not a device 

attached to the port and click Ok.
12. Highlight the next port that you want to configure and perform Steps 4 

through 11. 
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The following table provides information about the options on the port General tab.

Port Settings 
General Tab Description

RS Mode

Use this drop-down list to select the communications mode for the serial 
device that you will be connecting to this port.
• RS-232 (default RocketPort EXPRESS and RocketPort INFINITY)
• RS-422 (default RocketPort EXPRESS SMPTE)
• RS-485 Mode provides these choices.

- RS-485 2-wire (half-duplex) supports transmit and receive data. When 
data is transmitted, the Transmit Enable signal is activated, and the 
transmit receive device switches from receive to transmit 
automatically.

- RS-485 4-wire Master (full-duplex master) supports transmit and 
receive data, which means both signals are always active. The 
RocketPort EXPRESS/INFINITY is enabled by the Transmit Enable 
signal. This mode is the same as RS-422.

- RS-485 4-wire Slave (full-duplex slave) supports transmit and receive 
data. When data is transmitted, the Transmit Enable signal is 
activated, the transmit device goes active and starts sending data. 
When the data is not being sent, the transmit device is inactive. The 
receive device is always active. If you click RS-485, you may need to 
change settings in the RTS Toggle Options screen.

Note:

Override and Lock 
Baud Rate to

Default = None

This option allows you to lock selected ports.
You can select a value from the drop-down list or enter an appropriate value 
from the following standard baud rates: 300, 600, 1200, 1800, 2400, 3600, 
4800, 7200, 9600, 14400, 19200, 38400, 57600, 115200, 230400, 460800, or 
921600. 
The Quad/Octacable models support up to 921.6Kbps and the 8/16/32-port 
models with an interface box support up to 460.8Kbps.
After locking a baud rate, no matter what baud rate is selected in a host 
application, the actual rate used is the rate specified here.

RTS Toggle Options

This button opens the RTS Toggle Options popup, which provides the 
following features:
• Override and Lock to RS-485 Toggle Mode 

Use the Override and Lock to RTS Toggle Mode option to lock the port in 
RTS (Request to Send) toggle mode, then set the mode (low or high) as 
desired for RS-485 mode.

• RS-485 Toggle RTS Low 
Use the RTS Toggle RTS Low option to toggle the RTS output signal low 
during data transmission, which may be needed for relay devices for RS-
485.
If the option box is not checked, RTS is toggled high (asserted) during 
data transmission for RS-485 mode.

• Defaults 
Clicking the Defaults button returns all the values in the RTS Toggle 
Options popup to their default state:
- Override and Lock to RTS Toggle Mode = Disabled
- RTS Toggle RTS Low = Disabled
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Transmit Data Timeout 
Port Close

Default = 0

This option allows you to select the length of time to wait for data to clear the 
transmit buffer after a host application has closed the port. This is typically 
used with serial devices such as printers, to give the data sufficient time to 
flush through the system.

Map CD to DSR

Default = Disabled

This option is used in installations where there is no connection to the port’s 
DSR input.
Click this check box to cause the CD input to appear as DSR to the host 
application, and to perform hardware handshaking with CD rather than 
DSR.

Map 2 Stop Bits to 1

Default = Disabled

If your application is hard-coded to use two stop bits and you receive framing 
errors, click this check box to map 2 stop bits to 1 bit. 
Leave this check box blank to enable stop bits to pass through unchanged.

Wait on Physical 
Transmission before 
Completing Write

Default = Disabled

This option forces all write packets to wait until the transmit data has 
physically completed the transmission before returning completion to the 
host application. 
The default mode (check box not clicked) is to buffer the data in the transmit 
hardware buffer, and return completion as soon as the packet is in the buffer.

Emulate Modem 
Hardware RING Signal

Default = Disabled

Click this check box to emulate the ring indicator signal. 
If this box is checked and the port receives a RING signal (or an alternate 
code, as defined in the AT command set for the modem), it sends an RI signal 
to the communications application.

Block PnP search for 
attached serial device

Default = Disabled

This option disables plug and play from searching for a device attached to the 
serial port.
For example, data received during device discovery on a device is assumed to 
be a mouse to plug and play.

Clone: Apply all the 
settings to all ports

Default = Disabled

If this check box is not clicked, changes apply to the selected port only. 
If this check box is clicked, changes apply to all ports on this board.

Use Fast (Low Latency) 
Data Transfer

Default = Disabled

Use this option when you need to send or receive a small block of data on 
RocketPort EXPRESS/INFINITY adapters.

User-Friendly Port 
Name

You can enter a custom COM port name to identify this RocketPort in the 
Comtrol Drivers Management Console.

COM Name

The COM Name drop list allows you to renumber this COM port. If you see a 
COM port number followed by (in use), this means that Plug and Play sees 
those COM port numbers in use by another device.
If you rename the port to a COM name used by another port, a dialog appears 
indicating that the port is already in use.

Renumber All 
Subsequent Ports 
Relative to the Port

Default = Disabled

Use the Renumber All Subsequent Ports Relative to This Port option to renumber 
all subsequent ports on the RocketPort  relative to the port displayed in the 
COM name drop list.

Defaults

Default = Disabled
Click the Defaults button to return to the driver default values.

Port Settings 
General Tab Description
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Using Driver Configuration Files

The Comtrol Drivers Management Console supports saving device driver 
configuration files, which provides:
• Back-up for existing driver configuration settings
• Ability to configure multiple of the same devices with the same configuration 

parameters
• Save the driver configuration settings because you need to remove a driver 

version to install a new driver version and you want to reload the driver 
configuration settings into the new driver

Note: Configuration files must be for the same model with the same port density. 
For example, you cannot load a RocketPort EXPRESS configuration file 
onto a RocketPort INFINITY.

Configuration files are saved with a .DCF extension.

Saving Driver Configuration Files

Use the following procedure to create and save a configuration file.
1. After configuring the device and ports, click Save Configuration.
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2. Optionally, change the default file name and click Save.

Loading a Driver Configuration File

You must have previously saved a configuration file before you can load a 
configuration file.
The driver configuration file uploads in portions:
• If you highlight a device and click Load Configuration and Apply for the device-

level configuration parameters to reload on the device. 
• To load port-level configuration parameters, you must highlight a single port 

and click Load Configuration and Apply. You must upload each port's 
configuration parameters separately.

Loading Device 
Configuration

Use the following procedure to load the configuration file for device-level 
information for your device. 
1. If necessary, open the Comtrol Drivers Management Console using one of these 

methods:
• Windows Control Panel; go to your Control Panel and click on the 

Comtrol Drivers Management Console.
• Shortcut; located under Start > Comtrol >  RP EXPRESS INFINITY > 

Comtrol Drivers Management Console. 
2. Depending on your operating system, you may need to click Yes to the Do you 

want to allow the following program to make changes to this computer? User 
Account Control message.
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3. In the left pane, highlight the device for which you want to load the device-
level settings from the configuration file.

4. Click Load Configuration.
5. Browse to the location of the configuration file that you want to load.
6. Highlight the configuration 

file and click Open. The 
configuration file loads in a 
few moments. 

7. Make the appropriate 
choice for your situation:
• Click No to the 

ComtrolApplet message, 
if you are using the file 
to set up multiple 
devices with the same 
device-level settings.

• Click Yes to the 
ComtrolApplet message, 
if you are using the file 
to restore a specific 
device.  

8. Click Apply so that the configuration is saved on the device.
9. Go to the next procedure if you want to restore port settings from a 

configuration file.
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Loading Port 
Configuration

Use the following procedure to load the configuration file for port-level settings for 
your device. 
Note: Device driver configuration files must be for the same model with the same 

port density. For example, you cannot load a DeviceMaster PRO 
configuration file onto a DeviceMaster RTS or a configuration file for a 32-
port DeviceMaster RTS onto a 4-port DeviceMaster RTS.

1. If necessary, open the Comtrol Drivers Management Console using one of these 
methods:
• Windows Control Panel; go to your Control Panel and click on the 

Comtrol Drivers Management Console.
• Shortcut; located under Start > Program Files > Comtrol >  RP EXPRESS 

INFINITY > Comtrol Drivers Management Console. 
2. Depending on your operating system, you may need to click Yes to the Do you 

want to allow the following program to make changes to this computer? User 
Account Control message.

3. In the left pane, highlight the port for which you want to load the port-level 
settings from the configuration file.

4. Click Load Configuration.
5. Browse to the location of the configuration file that you want to load.
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6. Highlight the configuration file and click Open. The configuration file loads in 
a few moments. 

7. Make the appropriate choice for your situation:
• Click No to the ComtrolApplet message, if you are using the file to set up 

multiple devices with the same port-level settings.
• Click Yes to the ComtrolApplet message, if you are using the file to restore 

a specific device. 

8. Click Apply so that the configuration is saved on the device.
9. Repeat Steps 3 through 8 for each port that you want to restore.
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Removing the Adapter and Driver

This section discusses:
• Removing a RocketPort from an installation without removing the device 

driver from your system
• Removing the Device Driver and Adapter from your system

Removing a RocketPort

Use the following procedure to uninstall the device driver.
Note: Administrative privileges are required to remove device drivers on Windows 

operating systems newer than Windows Server 2003.
1. Right-click the RocketPort that you want to uninstall in the Tree View pane.
2. Click Uninstall.
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Removing the Device Driver and Adapter

Use the following procedure to remove the RocketPort device driver.
1. From the Start button, click the shortcut for your adapter: Comtrol > RP 

EXPRESS INFINITY Driver Installation Wizard.
2. Click Yes to the Do you want to allow this app to make changes to your device? 

message.
3. Click Next to start the Comtrol Driver Installation Wizard.
4. Click Remove All and Next.

5. Click Next to remove the driver.
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6. Click Next to clean up the driver removal.

7. Click Proceed to continue the driver removal process.

8. Click the Reboot My Computer button or Close.

• If you click Close, make sure that you reboot the system and remove the 
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adapter to complete the driver removal.
• If you click Reboot My Computer, click Ok. 

9. Shutdown the system and remove the RocketPort adapter.
10. If you want to totally remove the .exe driver assembly:

a. Delete any copies of the .exe driver assembly file residing on the system.
b. Delete the driver and devices using the Add > Remove Programs Control 

Panel.
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Troubleshooting and Technical Support

This section contains the following topics:
• Troubleshooting Checklist
• Comtrol Utility on Page 43

- Installing the Comtrol Utility on Page 43
- Using Port Monitor (PMon2) on Page 45
- Using Test Terminal on Page 48

• Before Calling Technical Support on Page 53
• Technical Support on Page 54

Troubleshooting Checklist

If you are having trouble with a RocketPort installation, try the following.
Note: Most customer problems reported to Technical Support are traced to cabling 

or network problems.

Issue Troubleshooting

Correct cabling?
Verify that you are using the correct types of cables in the 
correct places and that all cables are tightly connected. 
Refer to the appropriate RocketPort User Guide, you can 
download the latest version (Page 6) to verify cabling.

Correct Port 
Addressing?

Verify that you are addressing the port correctly. In many 
applications, device names above COM9 require the prefix 
\\.\ to be recognized. For example, to reference COM20, use 
\\.\COM20 as the file or port name.

Comtrol Drivers 
Management 
Console?

Verify that the RocketPort has installed using the Comtrol 
Drivers Management Console to confirm that the adapter 
displays. Install the device driver, if the adapter is not 
displayed.

Verify the 
Hardware?

Run the bootable diagnostics. 
You can download and burn a bootable Diagnostics CD for 
the RocketPort EXPRESS/INFINITY.

Test the Port or 
Ports?

Install the Comtrol Utility (Page 43) and use Test Terminal 
(Page 48).

Is this the Latest 
Driver? See Checking the Device Driver Version on Page 13.
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Port Does Not 
Open?

1. Open the Device Manager. 
2. Double-click Ports (COM & LPT) to expand the view.

Comtrol ports are displayed in the Device Manager, 
accordingly:
• DeviceMaster ports are Comtrol NS-Link ports
• RocketPort EXPRESS/INFINITY are Comtrol 

RocketPort Unity ports
If a yellow exclamation mark represents the port, right-click 
on the exclamation mark, and click Update Driver. See 
Updating the Driver on Page 14 for detailed procedures.

Monitor Port 
Activity? Install the Comtrol Utility (Page 43) and use Port Monitor.

Enable Verbose 
mode

You can optionally enable the Verbose Event Log option on 
the Device General tab for diagnostic purposes to initiate 
longer messages to be sent to the Event Log for your 
operating system. The added information can be useful 
when debugging communications and configuration 
problems.
Access the event log through the Administrative Tools Event 
Viewer option.

Issue Troubleshooting
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Comtrol Utility

The Comtrol Utility Package is innovative software for serial port communication, 
testing, monitoring and reporting for the RocketPort families using a Windows 
operating system.
The Comtrol Utility Package contains three useful software applications named 
Test Terminal, Port Monitor, and Peer Tracer for communicating directly, 
monitoring, and reporting statistics of any COM, RS-232, RS-422, and RS-485 
serial ports you have installed in a system.
The Comtrol Utility is available on the download site: http://
downloads.comtrol.com/utilities/windows/comtrol_utility. 
This subsection discusses the following topics:
• Installing the Comtrol Utility on Page 43
• Using Port Monitor (PMon2) on Page 45
• Using Test Terminal on Page 48

Installing the 
Comtrol Utility

Use the following procedure to install the Comtrol Utility package.
1. Execute the Comtrol_Utility_Package_x.xx.msi file, where x_xx is the Comtrol 

Utility version number.
2. Click Next.
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3. Click Next. 

4. Click Install.

5. Click Finish.
It is not necessary to 
reboot the PC after 
installation.

6. Go to Using Port Monitor 
(PMon2) on Page 45 or 
Using Test Terminal on 
Page 48 for procedures on 
using these applications.
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Using Port Monitor 
(PMon2)

This procedure will check whether the RocketPort can:
• Communicate through the RocketPort device driver 
• Determine if a port is open with an application

Testing Comtrol 
COM Ports 

If necessary, use Installing the Comtrol Utility on Page 43 to install Port Monitor.
1. Start Port Monitor, from the Start menu, select Programs > Comtrol > Utilities > 

Port Monitor (PMon2).

2. Click Add Ports using the icon or Tools > Add Ports, 

3. Click Driver, the appropriate 
product (or products), and click 
Ok.
• RocketPort EXPRESS/

INFINITY: click 
ROCKETPORT INFINITY

• DeviceMaster: click RPSHSI/
NSLINK
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4. If the RocketPort is communicating with the device driver for Windows, Port 
Monitor should display CLOSED status. If a port is open for an application, it 
displays as OPEN, and displays Actual Throughput, TxTotal and RxTotal 
statistics. 

Normally, there should be no data errors recorded or they should be very 
small. To find out what the actual errors are, scroll to the right. You will see 
three columns: Overrun Errors, Framing Errors, and Parity Errors.
If the errors are:
• Overrun Errors represent receive buffer overflow errors. If this is the case, 

you will have to configure either software or hardware handshaking to 
control the flow of data. The most common errors are Overrun errors.

• Framing Errors indicate that there is an synchronization error between the 
beginning of a data frame and the end of the data frame. A frame usually 
consists of a start bit, 8 data bits, and a stop bit or two. The framing error 
occurs if the stop bit is not detected or it occurs in the wrong time frame. 
Most causes for framing errors are electrical noise on the data lines, or 
differences in the data clocks of the RocketPort and the connected device.

• Parity Errors occur when parity is used and the parity bit is not what is 
expected. This can also be caused by noise on the data lines.

5. You can view additional statistics to Port Monitor by adding columns. Click 
Tools and Add Columns.
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6. Highlight or shift-click to add multiple statistics and click Ok.

Note: See the Port Monitor help system if you need an explanation of a 
column.

7. Scroll to the right to view the new columns. 

8. If you want to capture this session, you can save a current session as a report. 
To do this, select one of the following save options:
• File > Save As 
• File > Save - if the report already exists in an older format

• Save Active Session  button

Reports can be opened, viewed and re-used when needed. To open and view a 
report: 
a. Select File > Open or the Open Existing Session  button. The Open 

Session dialog appears.
b. Locate the session (table), you want to open and click the Open button.
Optionally, if you want to continue monitoring for an existing session, you 
need to activate the Polling Interval. 
• Select Tools > Settings to access the PMon2 Settings dialog
• Change the Polling Interval field to a value other than zero (0)

9. Leave Port Monitor open so that you can review events when using Test 
Terminal to test a port or ports.
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Using Test Terminal Test Terminal (WCom2) allows you to open a port, send characters and commands 
to the port, and toggle the control signals. This application can be used to 
troubleshoot communications on a port-by-port basis. 
• Send and Receive Test Data: This sends data out the transmit line to the 

loopback plug, which has the transmit and receive pins connected thus 
sending the data back through the Rx line to Test Terminal, which then 
displays the received data in the terminal window for that port. This test is 
only testing the Tx and Rx signal lines and nothing else. This test works in 
either RS-232 or RS-422 modes as both modes have transmit and receive 
capability. A failure in this test will essentially prevent the port from working 
in any manner.

• Loopback Test: This tests all of the modem control signals such as RTS, DTR, 
CTS, DSR, CD, and RI along with the Tx and Rx signals. When a signal is 
made HI in one line the corresponding signal line indicates this. The Loopback 
Test changes the state of the lines and looks for the corresponding state 
change. If it successfully recognizes all of these changes, the port passes. 
A failure on this test is not necessarily critical as it will depend on what is 
connected and how many signal lines are in use. For example, if you are using 
RS-232 in 3-wire mode (Transmit, Receive and Ground) a failure will cause no 
discernible issue since the other signals are not being used. If the port is 
configured for use as either RS-422 or RS-485 this test will fail and is expected 
to fail since RS-422 and RS-485 do not have the modem control signals that 
are present in RS-232 for which this test is designed.

The following procedures require a loopback plug to be placed on the port or ports 
that you want to test. A loopback plug was shipped with your RocketPort. If you 
need to build a replacement or additional loopback plugs, refer to the appropriate 
User Guide for your Comtrol device. See Downloading the Latest Software and 
User Guides on Page 6, if you need to build loopback plugs.

Opening Ports The following procedure shows how to use Test Terminal to send and receive test 
data to the serial ports. If necessary, use Comtrol Utility on Page 6 to install Test 
Terminal.
1. Stop all applications that may be accessing the ports such as RRAS or any 

faxing, or production software. See the appropriate help systems or manuals 
for instructions on stopping these services or applications. 
If another application is controlling the port, then Test Terminal will be unable 
to open the port and an error message will be shown.

2. Start Test Terminal (WCom2), from the Start menu, select Programs > Comtrol 
> Utilities > Test Terminal (WCom2).
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3. Select File > Open Port, the 
appropriate port (or ports) 
from the Open Ports drop-
down list and click Ok.
Note: If you left Port Monitor 

open from the previous 
subsection, you should 
show that the port is 
open.

Go to the next procedure to send 
and receive test data.

Sending and 
Receiving Test Data 
(RS-232/422 and 
RS-485: 4-Wire)

You can use this procedure to send and receive test data through the port or ports 
that you want to test.
1. If you have not done so, perform Steps 1 through 2 on Page 48.
2. Install the loopback plug onto the port (or ports) that you want to test.

See Downloading the Latest Software and User Guides on Page 6 if you need to 
build loopback plugs.

3. Select Port > Send and Receive Test Data.
You should see the 
alphabet scrolling 
across the port. If so, 
then the port installed 
properly and is 
operational. 
Note: If you left Port 

Monitor 
running, it 
should show 
data sent and 
received and 
show the 
average data 
throughput on 
the port.

4. Select Port > Send and 
Receive Test Data to stop 
the scrolling data.

5. You can go to the next 
procedure to run the Loopback Test on Page 50 if this is an RS-232 port.

If this test successfully completed, then the port is operational as expected.
Note: Do NOT forget to restart the communications application.
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Loopback Test (RS-
232)

The Loopback Test tests the modem control (hardware handshaking) signals. It 
only has meaning in RS-232 mode on serial connector interfaces with full RS-232 
signals. If performed under the following conditions, the test will always fail 
because full modem control signals are not present:
• RS-422
• RS-485
• RJ11 connectors
Use the following steps to run the Loopback Test.
1. If necessary, start Test Terminal (Page 48, Steps 1 through  2).
2. Click Port > Loopback Test.

This is a pass fail test and will take a second or two to complete. Repeat for 
each port that needs testing.

If the Loopback Test and the Send and Receive Test Data tests successfully 
complete, then the port is operational as expected.

Sending and 
Receiving Data (RS-
485: 2-Wire)

This procedure shows how to use Test Terminal (WCom2) to test two RS-485 (2-
wire, half-duplex) ports.
1. Start Test Terminal.
2. Open two ports RS-485 ports. This example uses COM40 and COM41.
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Test Terminal will open two windows, note that both ports show Receiving on 
the status bar.

3. Right-click both COM windows and remove the check mark for Receive.
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Both COM ports show Ready on the status bar.

4. Right-click in ONE window and select the Receive option from the pop up.
5. Right-click the OPPOSITE window and click Send.

The Status line shows Sending or Receiving.
In this case, COM40 is sending data and COM41 is receiving the data which is 
visually confirmed by the data scrolling across the COM41 window.
Note: If you do not see the data being received it MAY be necessary to also 

disable the RTS and DTR options from the right-click pop-up menu in 
each COM port.

6. Right-click and remove the check mark on the Sending COM port.
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7. Right-click and remove the check mark on the Receiving COM port.

Neither COM port is sending or receiving data but shows Ready on the Status 
bar.

8. Reverse the sending/receiving windows one at a time. Set the Receive option 
first, then in the opposite window, select the Send option.
The Status line shows Sending or Receiving in the reverse windows.

Data is now scrolling in the COM40 window. COM41 is static as it is not receiving 
data but transmitting data.

Before Calling Technical Support

Comtrol has a staff of support technicians available to help you. You should review 
Troubleshooting Checklist on Page 41 before calling Technical Support. If you call 
for Technical Support, please have the following information available.

Item Information

Adapter type

Adapter serial number

Driver part number and 
revision or version

Server computer make, 
model, and speed

Other serial port adapters 
installed in the server and 
their COM port numbers

Devices connected to the 
adapter
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Technical Support

If you need technical support, contact Comtrol using one of the following methods.

Contact Method Corporate Headquarters

Support http://www.comtrol.com/Support

Downloads
ftp://ftp.comtrol.com/html/default.htm
http://downloads.comtrol.com/html/default.htm

Web site http://www.comtrol.com

Phone
763. 957.6000
CST: 8AM-6PM (Excluding US Holidays)
54 - Technical Support RocketPort INFINITY/EXPRESS Driver User Guide: 2000634 Rev. A

http://www.comtrol.com/Support
ftp://ftp.comtrol.com/html/default.htm
http://www.comtrol.com


Appendix A.  Configuring Non-Plug and 
Play Devices

After installing the hardware and driver for Windows operating systems, you can 
use this discussion to configure non-plug and play COM ports.

Installing Non-Plug and Play Devices

Use the following procedure to install non-plug and play devices.
1. If you have not so yet, connect the device to a RocketPort port and turn on the 

device.
2. Open the Control Panel.
3. Go to the appropriate subsection to install non-plug and play modems or 

printers:
• Installing Modems on Page 55
• Installing Printers on Page 56

Installing Modems Use the following procedure to install non-plug and play modems.
1. If you have not done so yet, connect the modem (or modems) to the desired 

RocketPort port (or ports) and turn on the modem (or modems).
Note: This may take a few minutes, depending upon your system and the 

number of modems you are installing.
2. Open the Control Panel and click the Phone and Modem Options icon.
3. Click the Modems tab.
4. Click Add.
5. Click Don’t detect my modem. I will select it from a list and then click Next.
6. Click an appropriate modem model and then click Next.

Note: If you have a driver from the modem manufacturer, click Have Disk and 
browse to the location of the driver. If your modem is not listed, go to the 
modem manufacturer’s web site and download the appropriate driver.

7. Highlight the port or ports on to which you have connected modems.
8. Click Finish to complete the modem installation.
9. Configure modem properties as necessary. For assistance, use the Windows 

help system.
To use this modem or modems with RRAS, you can refer to the Comtrol RRAS 
Configuration Overview for Windows XP document.
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Installing Printers Use the following procedure to install a non-plug and play printer.
Note: If you want to install a plug and play printer, connect the printer to the 

appropriate serial port and the driver should automatically install. If it 
does not automatically install, use the following procedure as a guide with 
the printer manufacturers documentation.

1. Open the Control Panel and click the Printers and Faxes icon.
2. Click Next when this screen appears.
3. Click the Local printer attached to this computer item.
4. Click the COM port that corresponds to the port to which the printer is 

connected.
5. Click the Manufacturer, Printer type, and then click Next. 

Note: If you have a driver from the printer manufacturer, click Have Disk and 
browse to the location of the driver. If your printer is not listed, go to the 
printer manufacturer’s web site and download the appropriate driver.

6. Optionally, enter a printer name and then click Next.
7. Click Yes if you want to print a test page.
8. Click Finish to complete the installation.
9. Close the Printer and Faxes Control Panel.
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