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Overview

Test Terminal (WCom2)

The Test Terminal program enables you to open a port, send characters and 
commands to the port, and toggle the control signals. This application can be used 
to troubleshoot communications on a port-by-port basis.
Using Test Terminal and a loop-back plug on a port will help test serial ports and 
verify port operation by allowing you to send data out the port on the transmit 
side, loop the data back to the receive side and view the received data on the 
screen.
If you have a peripheral device connected to the serial port and know the device's 
command set, you can also send commands to the device. For example, if you have 
a modem connected to the port, you can use AT commands to query the modem 
and dial out to the host system.

Port Monitor (PMon2)

The Port Monitoring program offers a summary of all Comtrol device statistics in 
one view. It also enables you to verify operation of all Comtrol device ports from a 
single window. The statistics are displayed in a familiar spreadsheet model: each 
COM port is a horizontal row, and each vertical column displays a variable or 
value for the respective COM port, for simplified port monitoring and superior 
ease of use.
Port Monitor can also produce statistics and reports that can help you verify COM 
port operation and the connected peripherals. Some immediate feedback includes:
• The state of the modem control and status signals
• Open ports
• Raw byte input and output counts obtained from the device driver
• Port errors
The available statistics include:
• Instantaneous characters per second (CPS) calculations
• Minute, hour, and day CPS averages and peaks
• Carrier detect (CD) signal runtime and transition count
• Reports can be automatically generated on an hourly and/or daily basis, and 

can cover all ports collectively or a separate report for each port. You can also 
set how often the values are recalculated, fine-tuning thoroughness against 
system efficiency, and automatically run external batch files to perform 
additional processing and analysis.
Port Monitor and Test Terminal  User Guide: 2000485 Rev. B Overview  - 5



Installing the Appropriate Utility
Installing the Appropriate Utility

Test Terminal and Port Monitor are available in several Comtrol tools.
• RocketPort or RocketModem IV users will need to install the Comtrol 

Utility Package. See Comtrol Utility on Page 9 for information about locating 
and installing the Comtrol Utility. The Comtrol Utility Package supports the 
DeviceMaster families but typically customers prefer installing PortVision 
DX, which includes Port Monitor and Test Terminal and is a powerful 
DeviceMaster configuration and monitoring application.
Note: RocketPort or RocketModem IV also provides a bootable hardware 

diagnostic to test the adapter. The diagnostic is shipped with the 
product. Refer to the Software and Documentation CD for the diagnostic 
or locate it using the appropriate ftp download page at: ftp://
ftp.comtrol.com/html/default.htm.

• DeviceMaster users should install PortVision DX. See PortVision DX on Page 
13 for information about locating and installing PortVision DX.

Locating Comtrol Tools and Product Documentation

Loopback plugs are required for testing in Test Terminal (WCom2). A loopback 
plug is a serial port plug with pins wired together that you can use with an 
application to test serial ports.
A loopback plug was shipped with your product but you can build additional or a 
replacement using the document in the table below.

Product Utility Location

DeviceMaster PortVision DX ftp://ftp.comtrol.com/dev_mstr/
portvision_dxs/

RocketPort or 
RocketModem IV Comtrol Utility ftp://ftp.comtrol.com/utilities/windows/

comtrol_utility/

Documentation Location

DeviceMaster Installation and 
Configuration Guide

ftp://ftp.comtrol.com/dev_mstr/rts/docs/
dev_mstr_install_guide.pdf

RocketModem IV Hardware 
Installation

ftp://ftp.comtrol.com/rmodem/hw_doc/rm4/
rm4_install-doc.pdf

RocketPort EXPRESS User 
Guide

ftp://ftp.comtrol.com/rport_express/userguide/
rp_express_userguide.pdf

RocketPort EXPRESS SMPTE 
User Guide

ftp://ftp.comtrol.com/rport_express_smpte/
userguide/rp_express_smpte_userguide.pdf

RocketPort INFINITY User 
Guide

ftp://ftp.comtrol.com/rport_infinity/userguide/
rp_infinity_userguide.pdf

RocketPort Plus Universal PCI ftp://ftp.comtrol.com/rport/hw_doc/
universal_pci/plus/rp_upci_plus.pdf

RocketPort Plus 422 Universal 
PCI 

ftp://ftp.comtrol.com/rport/hw_doc/
universal_pc/plus_422/
RP_uPCI_Plus422_UserGuide.pdf

RocketPort Universal PCI ftp://ftp.comtrol.com/rport/hw_doc/
universal_pci/standard/rp_upci.pdf
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Comtrol Contact Information
Comtrol Contact Information

You can contact Comtrol Corporation using several methods.

Download Page Make sure that you installed the latest software. If you have not done so, check the 
Comtrol web site.

Customer Forum If you are connected to the internet, you can view any available FAQs for your 
product in the support forum.

Online Support You can access our online support instead of calling Technical Support. If you have 
not used this page before, you will need to register using your email address. 
Comtrol will email you a response within 24 hours (Monday through Friday).

Knowledge Center If you are connected to the internet, you can view the Comtrol Knowledge Center.

Phone Support You can contact Comtrol by calling 763-957-6000 (8AM to 6PM CST/USA).

RMA Information Access the RMA web page where you can locate a phone number to call, submit a 
request, or email a request to return a product. It also provides the procedures and 
address information.

RocketPort Universal PCI 
SMPTE

ftp://ftp.comtrol.com/rport/hw_doc/
universal_pci/smpte/
RP_uPCI_SMPTE_UserGuide.pdf

Documentation Location
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Comtrol Utility

The Comtrol Utility Package is innovative software for serial port communication, 
testing, monitoring and reporting for the RocketPort and RocketModem IV 
families.
Note: The Comtrol Utility Package supports the DeviceMaster families but 

typically customers prefer installing PortVision DX, which includes Port 
Monitor and Test Terminal and is a powerful DeviceMaster configuration 
and monitoring application.

This section includes the following topics:
• Overview
• Locating the Comtrol Utility
• Installing the Comtrol Utility on Page 10

Overview

The Comtrol Utility Package contains three useful software applications named 
Test Terminal, Port Monitor, and Peer Tracer for communicating directly, 
monitoring, and reporting statistics of any COM, RS-232, RS-422, and RS-485 
serial ports you have installed in a system.
The Comtrol Utility Package supports the following operating systems:
• Windows 2000
• Windows XP
• Windows Server 2003
• Windows Vista
• Windows Server 2008
• Windows 7
• Windows Server 2012
• Windows 8

Locating the Comtrol Utility

The Comtrol Utility is available on the Software and Documentation CD or you 
can download the latest version from: ftp://ftp.comtrol.com/utilities/windows/
comtrol_utility. The Comtrol Utility is an .msi file that automatically starts the 
installation procedure. 
The Comtrol Utility package includes the following applications that you can 
access from the Comtrol Program group:
• Port Monitor (PMon2) 
• Test Terminal (WCOM2)
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Installing the Comtrol Utility
Installing the Comtrol Utility

Use the following procedure to install the Comtrol Utility package.
1. Execute the Comtrol_Utility_Package_x.xx.msi file, where x_xx is the Comtrol 

Utility version number.
2. Click Next.

3. Click Next. 
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Installing the Comtrol Utility
4. Click Install.

5. Click Finish.

It is not necessary to reboot the PC after installation.
6. Go to Using Port Monitor (PMon2) on Page 19 or Using Test Terminal on Page 

23 for procedures on using these applications.
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PortVision DX

PortVision DX is Comtrol Corporation’s break-through software for efficiently 
locating, configuring and managing DeviceMaster over the network. 
This section contains the following topics:
• Overview
• Locating PortVision DX on Page 14
• Installing PortVision DX on Page 14

Overview

PortVision DX automatically detects Comtrol Ethernet-attached products 
physically attached to the local network segment so that you can configure the 
network address, upload firmware, and manage the following products:
• DeviceMaster family

- DeviceMaster PRO
- DeviceMaster RTS
- DeviceMaster Serial Hub
- DeviceMaster UP
- DeviceMaster 500

• IO-Link Master
• RocketLinx switches
In addition to identifying Comtrol Ethernet-attached products, you can use 
PortVision DX to display any third-party switch and hardware that may be 
connected directly to those devices. All non-Comtrol products and unmanaged 
RocketLinx switches are treated as non-intelligent devices and have limited 
feature support. For example, you cannot configure or update firmware on a third-
party switch.
PortVision DX supports the following operating systems:
• Windows XP
• Windows Server 2003
• Windows Vista
• Windows Server 2008
• Windows 7
• Windows Server 2012
• Windows 8
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Configuring Security Settings and PortVision DX
Configuring Security Settings and PortVision DX

The following list provides basic PortVision DX operations that are affected how 
the DeviceMaster interacts with PortVision DX when security is enabled using the 
web interface (SocketServer/NS-Link).
• PortVision DX must scan the DeviceMaster before configuring security.
• PortVision DX locates the DeviceMaster before setting either Secure Data Mode 

or Secure Config Mode.
• If PortVision DX discovers the DeviceMaster after setting security, the 

following conditions occur:
- The IP address of the DeviceMaster does not display.
- The Software Settings and Web Interface tabs are not present in the 

Properties page.
- The IP mode displays as DHCP without the ability to modify.
- The Upload and Reboot icons on the Launch Bar are grayed out and the 

options are disabled in the popup menus.
Note: If the DeviceMaster was previously configured with security, PortVision DX 

features are reduced.

Locating PortVision DX

PortVision DX is available on the Software and Documentation CD or you can 
download the latest version from: ftp://ftp.comtrol.com/dev_mstr/portvision_dx.
The PortVision DX application is an .msi file that automatically starts the 
installation procedure

Installing PortVision DX

Use the following procedure to install PortVision DX.
1. Execute the PortVision_DX[version].msi file. 
2. Click Next on the Welcome screen.
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Installing PortVision DX
3. Click I accept the terms in the License Agreement and Next. 

4. Click Next or optionally, browse to a different location and then click Next. 

5. Click Next to configure the shortcuts. 
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Installing PortVision DX
6. Click Install. 

7. Depending on the operating system, you may need to click Yes to the Do you 
want to allow the following program to install software on this computer? 
query.

8. Click Launch PortVision DX and Finish in the last installation screen.
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Installing PortVision DX
9. Click Launch PortVision DX and Finish in the last installation screen.

10. Depending on the operating system, you may need to click Yes to the Do you 
want to allow the following program to make changes to this computer? query.

11. Select the Comtrol Ethernet-attached products that you want to locate and 
then click Scan.

Note: If the Comtrol Ethernet-attached product is not on the local segment 
and it has been programmed with an IP address, it will be necessary to 
manually add the Comtrol Ethernet-attached product to PortVision DX.

If you need additional information about PortVision DX, refer to the Help 
system.

12. Go to Using Port Monitor (PMon2) on Page 19 or Using Test Terminal on Page 
23 for procedures on using these applications.

You can save time if you only scan for DeviceMasters.
Port Monitor and Test Terminal  User Guide: 2000485 Rev. B  PortVision DX  - 17



Installing PortVision DX
18 -  PortVision DX Port Monitor and Test Terminal  User Guide: 2000485 Rev. B



Using Port Monitor (PMon2)

You can use this subsection to test the RocketPort, RocketModem IV, or 
DeviceMaster driver installation. If you need to install the device driver, go to  
ftp://ftp.comtrol.com/html/default.htm to locate the latest driver and driver 
installation documentation.

Overview

This procedure will check whether the RocketPort, RocketModem IV, or 
DeviceMaster can:
• Communicate through the Comtrol device driver 
• Determine if a port is open with an application

Testing Comtrol COM Ports 

If necessary, use Comtrol Utility on Page 9 or PortVision DX on Page 13 to install 
Port Monitor.
1. Start Port Monitor.

• DeviceMaster: 
- If necessary, start PortVision DX. From the Start menu, select Programs 

> Comtrol > PortVision DX > PortVision DX or click the desktop shortcut.
- Select Tools > Applications > Port Monitor (PMon2).

• RocketPort or RocketModem IV: From the Start menu, select Programs > 
Comtrol > Utilities > Port Monitor (PMon2).

2. Click Add Ports using the icon or Tools > Add Ports, 
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Testing Comtrol COM Ports
3. Click Driver, the appropriate product (or 
products), and click Ok.
• RocketPort EXPRESS, RocketPort 

EXPRESS SMPTE, and INFINITY: 
click ROCKETPORT INFINITY

• DeviceMaster: click RPSHSI/NSLINK

• RocketPort Universal PCI (all 
models) and RocketModem IV: click 
ROCKETPORT 
 
 

4. If the RocketPort, RocketModem IV, or 
DeviceMaster is communicating with the 
device driver for Windows, Port Monitor 
should display CLOSED status. If a port 
is open for an application, it displays as 
OPEN, and displays Actual Throughput, 
TxTotal and RxTotal statistics. 

Normally, there should be no data errors recorded or they should be very 
small. To find out what the actual errors are, scroll to the right. You will see 
three columns: Overrun Errors, Framing Errors, and Parity Errors.
If the errors are:
• Overrun Errors represent receive buffer overflow errors. If this is the case, 

you will have to configure either software or hardware handshaking to 
control the flow of data. The most common errors are Overrun errors.

• Framing Errors indicate that there is an synchronization error between the 
beginning of a data frame and the end of the data frame. A frame usually 
consists of a start bit, 8 data bits, and a stop bit or two. The framing error 
occurs if the stop bit is not detected or it occurs in the wrong time frame. 
Most causes for framing errors are electrical noise on the data lines, or 
differences in the data clocks of the RocketPort, RocketModem IV, or 
DeviceMaster and the connected device.

• Parity Errors occur when parity is used and the parity bit is not what is 
expected. This can also be caused by noise on the data lines.
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Testing Comtrol COM Ports
5. You can view additional statistics to Port Monitor by adding columns. Click 
Tools and Add Columns.

6. Highlight or shift-click to add multiple statistics and click Ok.

Note: See the Port Monitor help system if you need an explanation of a 
column.

7. Scroll to the right to view the new columns. 

8. If you want to capture this session, you can save a current session as a report. 
To do this, select one of the following save options:
• File > Save As 
• File > Save - if the report already exists in an older format

• Save Active Session  button
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Testing Comtrol COM Ports
Reports can be opened, viewed and re-used when needed. To open and view a 
report: 
a. Select File > Open or the Open Existing Session  button. The Open 

Session dialog appears.
b. Locate the session (table), you want to open and click the Open button.
Optionally, if you want to continue monitoring for an existing session, you 
need to activate the Polling Interval. 
• Select Tools > Settings to access the PMon2 Settings dialog
• Change the Polling Interval field to a value other than zero (0)

9. Leave Port Monitor open so that you can review events when using Test 
Terminal to test a port or ports.
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Using Test Terminal

You can use the following procedure to test COM ports. If you need to install the 
RocketPort, RocketModem IV, or DeviceMaster device driver, go to  
ftp://ftp.comtrol.com/html/default.htm to locate the latest driver and driver 
installation documentation.
The following procedures require a loopback plug to be placed on the port or ports 
that you want to test. A loopback plug was shipped with your product. If you need 
to build a replacement or additional loopback plugs, refer to the appropriate User 
Guide for your RocketPort, RocketModem IV, or DeviceMaster. See Locating 
Comtrol Tools and Product Documentation on Page 6 if you need to build loopback 
plugs.

Overview

Test Terminal (WCom2) allows you to open a port, send characters and commands 
to the port, and toggle the control signals. This application can be used to 
troubleshoot communications on a port-by-port basis. 
• Send and Receive Test Data: This sends data out the transmit line to the 

loopback plug, which has the transmit and receive pins connected thus 
sending the data back through the Rx line to Test Terminal, which then 
displays the received data in the terminal window for that port. This test is 
only testing the Tx and Rx signal lines and nothing else. This test works in 
either RS-232 or RS-422 modes as both modes have transmit and receive 
capability. A failure in this test will essentially prevent the port from working 
in any manner.

• Loopback Test: This tests all of the modem control signals such as RTS, DTR, 
CTS, DSR, CD, and RI along with the Tx and Rx signals. When a signal is 
made HI in one line the corresponding signal line indicates this. The Loopback 
Test changes the state of the lines and looks for the corresponding state 
change. If it successfully recognizes all of these changes, the port passes. 
A failure on this test is not necessarily critical as it will depend on what is 
connected and how many signal lines are in use. For example, if you are using 
RS-232 in 3-wire mode (Transmit, Receive and Ground) a failure will cause no 
discernible issue since the other signals are not being used. If the port is 
configured for use as either RS-422 or RS-485 this test will fail and is expected 
to fail since RS-422 and RS-485 do not have the modem control signals that 
are present in RS-232 for which this test is designed.
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Opening Ports
Opening Ports

The following procedure shows how to use Test Terminal to send and receive test 
data to the serial ports. If necessary, use Comtrol Utility on Page 9 or PortVision 
DX on Page 13 to install Test Terminal.
1. Stop all applications that may be accessing the ports such as RRAS or any 

faxing, or production software. See the appropriate help systems or manuals 
for instructions on stopping these services or applications. 
If another application is controlling the port, then Test Terminal will be unable 
to open the port and an error message will be shown.

2. Start Test Terminal (WCom2).
• DeviceMaster: 

- If necessary, start PortVision DX. From the Start menu, select Programs 
> Comtrol > PortVision DX > PortVision DX or click the desktop shortcut.

- Select Tools > Applications > Test Terminal (WCom2).
• RocketPort or RocketModem IV: From the Start menu, select Programs > 

Comtrol > Utilities > Test Terminal (WCom2).
3. Select File > Open Port, the 

appropriate port (or ports) 
from the Open Ports drop list 
and Ok.
Note: If you left Port Monitor 

open from the previous 
subsection, you should 
show that the port is 
open.

Go to the appropriate procedure to 
send and receive test data.
• Sending and Receiving Test 

Data (RS-232/422/485: 4-
Wire) on Page 25

• Sending and Receiving Data 
(RS-485: 2-Wire) on Page 26
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Sending and Receiving Test Data (RS-232/422/485: 4-Wire)
Sending and Receiving Test Data (RS-232/422/485: 4-Wire)

You can use this procedure to send and receive test data through the RS-232/422/
485 (4-wire, full-duplex) port or ports that you want to test.
1. If you have not done so, perform Steps 1 and2 on Page 24.
2. Install the loopback plug onto the port (or ports) that you want to test.

See Locating Comtrol Tools and Product Documentation on Page 6 if you need 
to build loopback plugs.

3. Select Port > Send and Receive Test Data.
You should see the 
alphabet scrolling 
across the port. If so, 
then the port installed 
properly and is 
operational. 
Note: If you left Port 

Monitor 
running, it 
should show 
data sent and 
received and 
show the 
average data 
throughput on 
the port.

4. Select Port > Send and 
Receive Test Data to stop 
the scrolling data.

5. You can go to the next 
procedure to run the Loopback Test on Page 26 if this is an RS-232 port.

If this test successfully completed, then the port is operational as expected.
Note: Do NOT forget to restart the communications application.
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Loopback Test (RS-232)

The Loopback Test tests the modem control (hardware handshaking) signals. It 
only has meaning in RS-232 mode on serial connector interfaces with full RS-232 
signals. If performed under the following conditions, the test will always fail 
because full modem control signals are not present:
• RS-422
• RS-485
• RJ11 connectors
Use the following steps to run the Loopback Test.
1. If necessary, start Test Terminal (Page 24, Steps 1 and 2).
2. Click Port > Loopback Test.

This is a pass fail test and will take a second or two to complete. Repeat for 
each port that needs testing.

If the Loopback Test and the Send and Receive Test Data tests successfully 
complete, then the port is operational as expected.

Sending and Receiving Data (RS-485: 2-Wire)

This procedure shows how to use Test Terminal (WCom2) to test two RS-485 (2-
wire, half-duplex) ports.
1. Start Test Terminal.
2. Open two ports RS-485 ports. This example uses COM40 and COM41.
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Sending and Receiving Data (RS-485: 2-Wire)
Test Terminal will open two windows, note that both ports show Receiving on 
the status bar.

3. Right-click in both COM windows and remove the check mark for Receive.
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Sending and Receiving Data (RS-485: 2-Wire)
Both COM ports show Ready on the status bar.

4. Right-click in ONE window and select the Receive option from the pop up.
5. Right-click the OPPOSITE window and click Send.

The Status line shows Sending or Receiving.
In this case, COM40 is sending data and COM41 is receiving the data which is 
visually confirmed by the data scrolling across the COM41 window.
Note: If you do not see the data being received it MAY be necessary to also 

disable the RTS and DTR options from the right-click pop-up menu in 
each COM port.

6. Right-click and remove the check mark on the Sending COM port.
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Sending and Receiving Data (RS-485: 2-Wire)
7. Right-click and remove the check mark on the Receiving COM port.

Neither COM port is sending or receiving data but shows Ready on the Status 
bar.

8. Reverse the sending/receiving windows one at a time. Set the Receive option 
first, then in the opposite window, select the Send option.
The Status line shows Sending or Receiving in the reverse windows.

Data is now scrolling in the COM40 window. COM41 is static as it is not receiving 
data but transmitting data.
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Sending and Receiving Data (RS-485: 2-Wire)
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