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Overview

Product Overview

The RocketPort EXPRESS SMPTE is a high-speed in-server serial expansion card 
for use in a PCI-Express (PCIe) compatible slot in a host system. The RocketPort 
EXPRESS SMPTE was designed to support speeds up to 921Kbps and supports 
RS-422 exclusively, in either DCE or DTE mode.
The RocketPort EXPRESS SMPTE uses Comtrol Application Specific Integrated 
Circuit (ASIC) technology to replace most hardware functionality to minimize 
components, including:
• The processor
• A serial controller
• Bus interface logic and other miscellaneous logic
You can install up to four RocketPort EXPRESS SMPTE cards in one computer, 
providing a maximum of 32 additional serial ports. The RocketPort EXPRESS 
SMPTE is an 8-port card with a DB9F interface box.

Before Installing the RocketPort EXPRESS SMPTE

If you are planning on installing the RocketPort EXPRESS SMPTE in a Windows 
system make sure that you have placed the device driver assembly to a location 
that is available to the host system before installing the card in the host. 
You can use the Software and Documentation CD to locate the latest device drivers 
and documentation or the links in the following table.
You may want to record the model and serial number of the RocketPort EXPRESS 
SMPTE before installing the card in the event you need to call technical support.

Locating the Latest Drivers and Documentation

This table contains links the software and installation documentation. Optionally, 
you can locate the latest device drivers, software, and installation documentation.

Software or 
Document Location

Device drivers ftp://ftp.comtrol.com/html/rp_express_smpte_drivers.htm

Diagnostic and 
Utilities ftp://ftp.comtrol.com/html/rp_express_smpte_diag.htm

User Guides ftp://ftp.comtrol.com/html/rp_express_smpte_docs.htm

ftp://ftp.comtrol.com/html/rp_express_smpte_drivers.htm
ftp://ftp.comtrol.com/html/rp_express_smpte_diag.htm
ftp://ftp.comtrol.com/html/rp_express_smpte_docs.htm
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Card and Interface Installation

This section discusses the following:
• Installing the Card
• Attaching an Octacable Interface Cable on Page 8
• Attaching an Interface Box on Page 9
• Installing a Rackmount Interface Box on Page 10

Installing the Card

Use the following procedure to install a RocketPort EXPRESS SMPTE card.
1. Turn off the host computer. 
2. If necessary, set the DCE/DTE DIP switch for your environment.

• DCE mode: verify that the DIP switches are set to ON for DCE mode on 
the appropriate ports.

• DTE mode: set the switches to OFF as needed for any ports that require 
DTE mode.

3. Remove the system cover from your computer.
4. Select a PCI-Express (PCIe) compatible slot.
5. Remove the slot cover or release the clamp.
6. If necessary, replace the low-profile mounting bracket with the standard 

mounting bracket shipped with the RocketPort EXPRESS SMPTE.
7. Insert the card into the slot and seat it securely. 
8. Reinstall the expansion slot retaining screw or clamp.

Note: You may want replace the system cover after the driver is installed and 
running in the event that you need to change the DTE/DCE switch 
setting.

DIP Switch

OFF
ON

DCE = ON
DTE = OFF

Factory Default Setting = DCE
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Attaching an Octacable Interface Cable

Do not connect an interface to the card when the host 
system is powered on, this can cause the card to fail. 

9. Attach the appropriate interface (octacable or interface box) to the RocketPort 
EXPRESS SMPTE:
• Attaching an Octacable Interface Cable on Page 8
• Attaching an Interface Box on Page 9
• Installing a Rackmount Interface Box on Page 10

Attaching an Octacable Interface Cable

Use this procedure to complete the octacable installation.
1. Make sure that the host system is powered off before connecting the cable.
2. Attach the 68-pin end of the octacable to the card. 

Make sure that the connectors are properly 
aligned and forcefully push the connector of 
the Octacable with a rocking motion into the 
card connector. Make sure that the connector 
is seated tightly before tightening the 
retaining screws on the connector. 

3. Tighten the retaining screws. 
4. Power on the host system.
5. Click Cancel if a Found New Hardware message appears on a Windows 

operating system.
Execute the device driver assembly to start the driver installation.
For other operating system device drivers, see Locating the Latest Drivers and 
Documentation on Page 5.

6. After installing the driver, you should verify that the ports are functioning 
properly and then connect your serial devices. 
You can use the Troubleshooting section on Page 15 for port testing 
procedures.
Refer to Connecting Serial Devices on Page 11 for information about 
connecting serial devices.

Caution

Caution
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Attaching an Interface Box

Attaching an Interface Box

Use this procedure to complete the installation with an interface box.
Do not connect the cable to the RocketPort EXPRESS SMPTE card or 
interface box when the computer is powered on. The interface is not 
hot-swappable. 
 
Connecting the cable to the RocketPort EXPRESS SMPTE card or 
interface box while the computer is powered on may damage the 
electronics on the card or interface box.

1. Make sure that the host system is powered off before connecting the cable.
2. Attach the LFH60 end of the interface cable to the RocketPort EXPRESS 

SMPTE card and the DB37 end to the connector the interface box. 
Make sure that the connectors are properly 
aligned. Do NOT use force when connecting the 
cables to the host adapter card.

3. Tighten the retaining screws.
4. Power on the host system.
5. Click Cancel if a Found New Hardware message 

appears on a Windows operating system.
Execute the device driver assembly to start the 
driver installation.
For other operating system device drivers, see 
Locating the Latest Drivers and Documentation on 
Page 5.

6. After installing the driver, you should verify that the ports are functioning 
properly and then connect your serial devices. 
You can use the Troubleshooting section on Page 15 for port testing 
procedures.
Refer to Connecting Serial Devices on Page 11 for information about 
connecting serial devices.

Caution

Caution
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Installing a Rackmount Interface Box

Installing a Rackmount Interface Box

Rackmount interface boxes are sturdy enough to allow you to stack several units 
on a shelf, or you can mount it directly into a rack.

Do not connect the cable to the RocketPort EXPRESS SMPTE card or 
interface box when the computer is powered on. The interface is not 
hot-swappable. 
 
Connecting the cable to the RocketPort EXPRESS SMPTE card or 
interface box while the computer is powered on may damage the 
electronics on the card or interface box.

1. Make sure that the host system is powered off before connecting the cable.
2. Place the Rackmount interface box on a stable surface or attach the brackets 

to the interface box using the screws supplied with the unit and attach the 
bracket into your rack.

3. Attach the cable shipped with the card between the interface box and the card.
Make sure that the connectors are 
properly aligned. Do NOT use force 
when connecting the cables to the host 
adapter card. 

4. Power on the host system.
5. Click Cancel if a Found New Hardware 

message appears on a Windows operating 
system.
Execute the device driver assembly to 
start the driver installation.
For other operating system device drivers, see Locating the Latest Drivers and 
Documentation on Page 5.

6. After installing the driver, you should verify that the ports are functioning 
properly and then connect your serial devices. 
You can use the Troubleshooting section on Page 15 for port testing 
procedures.
Refer to Connecting Serial Devices on Page 11 for information about 
connecting serial devices.

Caution

Caution
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Connecting Serial Devices

This section provides information about the RocketPort EXPRESS SMPTE 
connectors, in the event that you need to build cables or loopback plugs. 
A loopback plug is a serial port plug with pins wired together that you can use 
with application (for example, the diagnostic, Test Terminal, or minicom) to test 
serial ports. See Before Calling Technical Support on Page 15 for information 
about using the test application shipped with the RocketPort EXPRESS SMPTE.

DTE Versus DCE

Most devices, except modems, are Data Terminal Equipment (DTE) devices. 
Modems are Data Communication Equipment (DCE) devices. RocketPort 
EXPRESS SMPTE ports are set to DCE by default. 
The RocketPort EXPRESS SMPTE conforms to the ANSI/SMPTE 207M-1997 
Television – Digital Control Interface – Electrical and Mechanical Characteristics 
standard. The Society of Motion Picture and Television Engineers (SMPTE) 207M 
protocol permits the control of video and audio tape decks for editing purposes and 
can be used to connect controlled device such as, video routers and servers. 
DTE and DCE are controlled with the DIP switch on the RocketPort EXPRESS 
SMPTE. See Card and Interface Installation on Page 7 for information.

DB9 Serial Cables and Loopback Plugs

The following figures and table illustrate the signals present on DB9 connectors if 
you need to build your own null-modem or straight-through DB9 serial cables. The 
RocketPort EXPRESS SMPTE provides female DB9 SMPTE port connections that 
comply with the SMPTE 207M standard so that you can easily connect Sony DB9 
type devices.
• DB9 Signals on Page 12
• Straight-Through Cables (DCE) on Page 12
• Null-Modem Cables (DTE) on Page 12
• DB9 Loopback Plugs on Page 12
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DB9 Signals

DB9 Signals Refer to the manufacturer’s installation documentation 
if you need help with the connector pinouts or cabling for 
the serial device. 

Note: DTE and DCE mode are controlled with the DIP switch on the RocketPort 
EXPRESS SMPTE. See Installing the Card on Page 7 for information. The 
factory default is set to DCE. Verify that the DIP switches are ON (down) for 
DCE mode.

Straight-Through 
Cables (DCE)

Use the following figure if you need to build an RS-422 straight-through cable for 
DCE devices.

Null-Modem Cables 
(DTE)

Use the following figure if you need to build an RS-422 null-modem cable for DTE 
devices.

Note: RS-422 signals are not standardized and each serial manufacturer uses 
different pinouts. Refer to the serial device documentation to determine the 
pinouts for the signals above.

DB9 Loopback Plugs RocketPort EXPRESS SMPTE models with DB9 
connectors on the interface are shipped with a a single 
loopback plug.
Wire the following pins together to build additional 
plugs or replace a missing loopback plug.
• Pins 2 to 8
• Pins 3 to 7

SMPTE 207M DB9 Female Connector

Pin DCE Mode
(SMPTE) DTE Mode

1 Chassis Ground Chassis Ground

2 RxD- TxD-

3 TxD+ RxD+

4-6 Not used Not used

7 RxD+ TxD+

8 TxD- RxD-

9 Chassis Ground Chassis Ground

Pin 1Pin 5

Pin 6Pin 9

Female

TxD+
TxD-
RxD+

Signal

 

3
8
7

 Pins

RxD-     

RocketPort Sony DB9 ConnectorDCE Mode

2

3
8
7

 Pins

2

TxD+
TxD-
RxD+

Signal

RxD-     

TxD+
TxD-
RxD+

Signal

 
 

7
2

3

 Pins
RxD+
RxD-

Signal

TxD+
TxD-RxD-            8     

DTE Serial DeviceRocketPort DTE Mode

 RS-422 (Back View)

Pin 1Pin 5

Pin 6Pin 9

SMPTE Loopback
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Building Interfaces

68-Pin VHDCI Connector

Use the following table if you need to build a cable for a proprietary serial device. 

Pins DCE DTE Pins DCE DTE

1 TXD-1 RXD-1 19 TXD-5 RXD-5

2 TXD+1 RXD+1 20 TXD+5 RXD+5

3 RXD-1 TXD-1 21 RXD-5 TXD-5

4 RXD+1 TXD+1 22 RXD+5 TXD+5

5 TXD-2 RXD-2 23 TXD-6 RXD-6

6 TXD+2 RXD+2 24 TXD+6 RXD+6

7 RXD-2 TXD-2 25 RXD-6 TXD-6

8 RXD+2 TXD+2 26 RXD+6 TXD+6

9 TXD-3 RXD-3 27 TXD-7 RXD-7

10 TXD+3 RXD+3 28 TXD+7 RXD+7

11 RXD-3 TXD-3 29 RXD-7 TXD-7

12 RXD+3 TXD+3 30 RXD+7 TXD+7

13 TXD-4 RXD-4 31 TXD-8 RXD-8

14 TXD+4 RXD+4 32 TXD+8 RXD+8

15 RXD-4 TXD-4 33 RXD-8 TXD-8

16 RXD+4 TXD+4 34 RXD+8 TXD+8

17 N/C N/C 35-50 N/C N/C

18 GND GND 51 GND GND

52-68 N/C N/C

34
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68-Pin VHDCI Connector
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Troubleshooting

If you are experiencing problems with the RocketPort EXPRESS SMPTE, review 
the troubleshooting procedures for your system before calling Technical Support.

Before Calling Technical Support

Review the following information before calling Technical Support because they 
will request that you perform many of the procedures or verifications before they 
will be able to help you diagnose a problem.
• Verify the cabling using Connecting Serial Devices on Page 11. 

Note: Most customer problems reported to Comtrol Technical Support are 
eventually traced to cabling or network problems.

• If you have not done so, run the diagnostics (RocketPort EXPRESS SMPTE 
Diagnostics on Page 15).

• Verify that you have installed the latest RocketPort EXPRESS SMPTE device 
driver, see Locating the Latest Drivers and Documentation on Page 5.
If necessary, remove or update the existing driver using the procedures in the 
RocketPort EXPRESS SMPTE Device Driver Installation Guide for Windows 
or README file packaged with the FreeBSD, Linux, QNX, or SCO 
OpenServer driver.

If none of the above work, you can refer to one of these subsections:
• Troubleshooting Windows Systems on Page 17
• Troubleshooting Linux Systems on Page 24

RocketPort EXPRESS SMPTE Diagnostics

This subsection describes how to run the bootable diagnostic CD to verify that the 
RocketPort EXPRESS SMPTE hardware is functioning properly. The RocketPort 
EXPRESS SMPTE is shipped with a bootable CD that executes hardware 
diagnostics.
In the event that you cannot locate the CD, you can download (Page 5) the latest 
version and burn the .iso image to a CD-ROM. 
Note: An .iso file cannot be copied onto a CD but must be burned using an 

application that burns the image to the CD. If you do not have an 
application available, you can use a freeware application that is on the 
Comtrol Software and Documentation CD or download it at: ftp://
ftp.comtrol.com/iso/IsoBurner/.

You can use the diagnostic to:
• Confirm that the hardware is functioning
• Determine resolutions to conflicts during installation
• Perform a stress test on all RocketPort EXPRESS SMPTE ports in the system
The diagnostic requires a loopback plug to test a port or ports. A single loopback 
plug is shipped with the RocketPort EXPRESS SMPTE. You can build additional 
loopback plugs or move the loopback plug to the port you want to test. See 
Connecting Serial Devices on Page 11 if you want to build loopback plugs.

ftp://ftp.comtrol.com/rport_express/diag
ftp://ftp.comtrol.com/iso/IsoBurner/
ftp://ftp.comtrol.com/iso/IsoBurner/
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Running the Bootable Diagnostic

If you cannot locate the Diagnostic CD, you can burn a replacement with the .iso 
file on the Comtrol Software and Documentation CD shipped with your adapter or 
download the latest version from the ftp site (Page 5).

Running the 
Bootable Diagnostic

Use the following procedure to run the diagnostics.
Note: If the diagnostic goes into sleep mode while unattended, press the Num Lock 

key to activate the screen. Use Ctrl/Alt Delete to kill the diagnostic process 
at any time.

1. Insert the bootable CD that contains the diagnostic and restart your machine.
Note: If the Diagnostic CD does not boot the PC, you may need to change your 

BIOS settings so that the PC can boot from a CD drive.
The diagnostic starts automatically and takes a few minutes before the first 
screen appears.
Note: If the diagnostics did not detect the RocketPort EXPRESS SMPTE, the 

adapter has a hardware failure, contact Technical support (Page 25).
2. Press Enter at the Copyright screen to begin the diagnostic.
3. Select from the following options and use the appropriate steps.

• Testing a Port or Ports
• Stress Testing the RocketPort EXPRESS SMPTE

Testing a Port or 
Ports

4. Enter 1 to 4 and then press Enter to test a port or ports on a specific RocketPort 
EXPRESS SMPTE or multiple adapters. 

5. Press Enter to test all ports on the RocketPort EXPRESS SMPTE or enter the 
port number of a port that you want to test and then Enter.

6. Place the loopback plug on the appropriate port and press Enter. If you are 
testing all of the ports and have only one loopback plug, you must move it from 
port to port during the test.
Note: Use Shift Page Up/Down to review the diagnostic report. 

To end the diagnostic, you may need to select b to return to a screen that contains 
a q to quit. A summary is displayed if you select q. Type reboot, select Enter, and 
remove the CD from the drive when prompted.

Stress Testing the 
RocketPort 
EXPRESS SMPTE

The stress test requires a loopback plug for each port on each card.
Select S and press Enter to run the stress test on all RocketPort EXPRESS SMPTE 
cards installed in the system. Make sure that you have a loopback port installed 
and each port on each adapter.
The stress test uses a default configuration to simultaneously stream data to all 
ports of the RocketPort EXPRESS SMPTE cards in a system until you stop the 
test. 
To stop the test and review the results of the stress test, enter S.

Exiting the 
Diagnostic

To end the diagnostic, you may need to select b to return to a screen that contains 
a q to quit. Type reboot, select Enter, and remove the CD from the drive when 
prompted.

If the Diagnostic 
Fails

If the diagnostics fails, try one of the following before contacting Technical 
Support:
1. Turn off the power and reseat the RocketPort EXPRESS SMPTE card into the 

slot.
2. Try running the diagnostics again. If they fail again, you may have a bad port, 

contact Technical Support on Page 25.
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Troubleshooting Windows Systems

Troubleshooting Windows Systems

If you are using a RocketPort EXPRESS SMPTE driver on a Windows system and 
the diagnostic verified that the card is functional, you can check the following:
1. Verify that the RocketPort EXPRESS SMPTE has installed by checking the 

Device Manager to verify that the RocketPort EXPRESS SMPTE card 
displays.

2. Verify that you are addressing the port correctly.
In many applications, device names above COM9 require the prefix \\.\ in 
order to be recognized. For example, to reference COM20, use \\.\COM20 as 
the file or port name.

3. After driver installation, if a port does not open; go to Ports COM & LPT, right-
click on the yellow exclamation mark on the port, and click Update Driver. Use 
the same procedure used when installing the ports that are detected with plug 
and play systems.

4. Enable the Verbose Event Log feature on the Options tab of the RocketPort 
EXPRESS SMPTE driver and then reboot the server.

5. Install and use one of the tools in the Comtrol Utility package. Use the 
following subsection, Comtrol Utility, below for installation and adapter 
testing procedures.

Comtrol Utility The Comtrol Utility is available on the Software and Documentation CD or you 
can download (Page 5) the latest version. The file is a self-extracting zip file that 
automatically starts the installation procedure. It is not necessary to reboot the 
PC after installation.
The Comtrol Utility package includes the following applications that you can access 
from the Comtrol Program group:
• Port Monitor (PortMon2) checks for errors, modem control, and status signals. 

In addition, it provides you with raw byte input, output counts, and confirm 
that the device driver is functioning. It can determine if the ports are in use by 
another application.

• Test Terminal (WCOM2) can be used to troubleshoot communications on a port-
by-port basis (Using Test Terminal to Test a Port on Page 22). Test Terminal 
requires a loopback plug. You can build a loopback plug if you are missing the 
loopback plug shipped with the adapter (DB9 Loopback Plugs on Page 12).

Use the following 
procedure to install the 
Comtrol Utility package.
1. Execute the 

Comtrol_Utility_Pack
age_x.xx.msi file, 
where x_xx is the 
Comtrol Utility 
version number.

2. Click Next. 
 
 
 
 
 
 
 
 

ftp://ftp.comtrol.com/utilities/windows/comtrol_utility
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Comtrol Utility

3. Click Next. 

4. Click Install.

5. Click Finish.
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Using PortMon to Test the Driver Installation

6. Go to Using PortMon to Test the Driver Installation on Page 19.

Using PortMon to 
Test the Driver 
Installation

You can use PortMon to check whether the RocketPort EXPRESS SMPTE can 
communicate through the device driver for Windows. If necessary, use Comtrol 
Utility on Page 17 to install PortMon.
1. From the Start menu, select Programs > Comtrol > Utilities > Port Monitor 

(PortMon2).

2. Click Add Ports using the icon or Tools > Add Ports, click Driver, ROCKETPORT, 
and click Ok.

3. If the RocketPort EXPRESS SMPTE is communicating with the device driver 
for Windows, Port Monitor should display CLOSED status. If a port is open for 
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Using PortMon to Test the Driver Installation

an application, it displays as OPEN, and displays Actual Throughput, TxTotal 
and RxTotal statistics.

Normally, there should be no data errors recorded or they should be very 
small. To find out what the actual errors are, scroll to the right. You will see 
three columns: Overrun Errors, Framing Errors, and Parity Errors.
If the errors are:
• Overrun Errors represent receive buffer overflow errors. If this is the case, 

you will have to configure either software or hardware handshaking to 
control the flow of data. The most common errors are Overrun errors.

• Framing Errors indicate that there is an synchronization error between the 
beginning of a data frame and the end of the data frame. A frame usually 
consists of a start bit, 8 data bits, and a stop bit or two. The framing error 
occurs if the stop bit is not detected or it occurs in the wrong time frame. 
Most causes for framing errors are electrical noise on the data lines, or 
differences in the data clocks of the RocketPort EXPRESS SMPTE and the 
connected device.

• Parity Errors occur when parity is used and the parity bit is not what is 
expected. This can also be caused by noise on the data lines.
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Using PortMon to Test the Driver Installation

4. You can view additional statistics to Port Monitor by adding columns. Click 
Tools and Add Columns.

5. Highlight or shift-click to add multiple statistics and click Ok.

Note: See the Port Monitor help system if you need an explanation of a 
column.
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Using Test Terminal to Test a Port

6. Scroll to the right to view the new columns. 

7. If you want to capture this session, you can save a current session as a report. 
To do this, select one of the following save options:
• File > Save As 
• File > Save - if the report already exists in an older format

• Save Active Session  button

Reports can be opened, viewed and re-used when needed. To open and view a 
report: 
a. Select File > Open or the Open Existing Session  button. The Open 

Session dialog appears.
b. Locate the session (table), you want to open and click the Open button.
Optionally, if you want to continue monitoring for an existing session, you 
need to activate the Polling Interval. 
• Select Tools > Settings to access the PMon2 Settings dialog
• Change the Polling Interval field to a value other than zero (0)

8. Leave Port Monitor open so that you can review events when using Test 
Terminal to test a port or ports.

Using Test Terminal 
to Test a Port

Test Terminal (WCom2) allows you to open a port, send characters and commands 
to the port, and toggle the control signals. This application can be used to 
troubleshoot communications on a port-by-port basis. 
The Send and Receive Test Data option sends data out the transmit line to the 
loopback plug, which has the transmit and receive pins connected thus sending 
the data back through the Rx line to Test Terminal, which then displays the 
received data in the terminal window for that port. This test is only testing the Tx 
and Rx signal lines and nothing else. A failure in this test will essentially prevent 
the port from working in any manner.
The Loopback Test option tests all of the modem control signals such as RTS, DTR, 
CTS, DSR, DCD, and RI along with the Tx and Rx signals. 
Note: This test will fail and is expected to fail since RS-422 does not have the 

modem control signals that are present in RS-232 for which this test is 
designed.

The following procedure shows how to use Test Terminal to send and receive test 
data to the serial ports and run a loopback test. If necessary, install the Comtrol 
Utility package using Comtrol Utility on Page 17.
1. Stop all applications that may be accessing the ports such as RRAS or any 

faxing or production software. See the appropriate help systems or manuals 
for instructions on stopping these services or applications. 
If another application is controlling the port, then Test Terminal will be unable 
to open the port and an error message will be shown.
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Using Test Terminal to Test a Port

2. From the Start menu, select Programs > Comtrol > Utilities > Test Terminal 
(WCom2).

3. Select File > Open Port, the 
appropriate port (or ports) 
from the Open Ports drop list 
and Ok.
Note: If you left Port Monitor 

open from the previous 
subsection, you should 
show that the port is 
open.

4. Install the loopback plug (DB9 
Loopback Plugs on Page 11) 
onto the port (or ports) that 
you want to test.

5. Select Port > Send and Receive 
Test Data.

You should see the 
alphabet scrolling 
across the port. If so, 
then the port installed 
properly and is 
operational. 
Note: If you left Port 

Monitor 
running, it 
should show 
data sent and 
received and 
show the 
average data 
throughput on 
the port.

6. Select Port > Send and 
Receive Test Data to stop 
the scrolling data.

7. Close Test Terminal.
If this test successfully completed, then the port is operational as expected.
Note: Do NOT forget to restart the communications application.
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Troubleshooting Linux Systems

You can use the following subsections to test the serial ports. 

lcom(1) Comtrol has available lcom(1), which is a multiport serial I/O test program. You 
can use lcom in test mode to send test data to any serial port.
lcom is available on the Software and Documentation CD or you can download the 
latest version.
Note: For assistance using lcom, use the manual page, lcom(1) that accompanies 

the program.

File Transfer You can transfer a file using the following information. The default settings are 
9600, 8, n, 1, and no parity. To send a file you can redirect output to a device; for 
example:

cat /etc/inittab > /dev/ttyRP0

Sends the contents of the /etc/inittab file to the ttyRP0 device at 9600 baud, 8, n, 1, 
and no parity.

Changing Serial 
Port Settings (stty)

Use the following information if you need assistance changing or viewing the baud 
rate settings.
To change the baud rate, use the following example, which changes the baud rate 
to 19200:

stty 19200 </dev/ttyRP0

To view the current serial port settings for ttyRP0, enter:
stty -a </dev/ttyRP0

Note: Settings changes via stty are only valid during current log in session. For 
permanent setting changes, use the /etc/inittab file.

Setting Up 
Terminals and 
Modems (mgetty, 
getty)

Add the appropriate line or lines to the /etc/inittab file then restart.
Terminal Example:

T0:23:respawn:/sbin/agetty -L ttyRP0 57600 vt100

Modem Example:
T1:23:respawn:+/sbin/mgetty -m ‘”” AT&F OK’ -D -x9 -s 115200 ttyRP0

Note: If necessary, see the manual pages for more information on mgetty.

Testing with 
minicom

You can also use minicom, which shipped with most Linux distributions, to test the 
serial ports. A Comtrol document is available for using minicom.

ftp://ftp.comtrol.com/tech_misc/linux/minicom_doc/minicom.txt
ftp://ftp.comtrol.com/utilities/linux/lcom/v1_01
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Technical Support

Comtrol has a staff of support technicians available to help you. You should review 
Before Calling Technical Support on Page 15 before calling Technical Support. If 
you call for Technical Support, please have the following information available:
• Model number
• Serial number
• Interface type
• Operating system type, release, and service package, and if Linux, the kernel 

version
• Device driver version
• Computer make, model, speed, and single or dual processor
• List other devices in the computer and their addresses

Comtrol Corporate Headquarters

Support http://www.comtrol.com/pub/en/Support

Device drivers ftp://ftp.comtrol.com/html/rp_express_smpte_drivers.htm

Diagnostic and 
Utilities ftp://ftp.comtrol.com/html/rp_express_smpte_diag.htm

Web site http://www.comtrol.com

Phone 763.494.4100

Downloads ftp://ftp.comtrol.com/html/default.htm

ftp://ftp.comtrol.com/html/rp_express_smpte_diag.htm
http://www.comtrol.com/pub/en/Support
http://www.comtrol.com
ftp://ftp.comtrol.com/html/default.htm
ftp://ftp.comtrol.com/html/rp_express_smpte_drivers.htm
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