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Overview

Product Overview
The RocketPort uPCI SMPTE series multiport serial card fits into the PCI slot of a
personal computer, and uses a 43 MHz processor that is specifically designed to
process asynchronous serial communications.
The RocketPort uPCI SMPTE supports RS-422 exclusively, in either DTE or DCE
mode. It supports 3.3 and 5.0 volt PCI bus architecture and is compatible with 32and 64-bit PCI slots. The RocketPort uPCI SMPTE card supports communications
speeds up to 921,600 baud.
The RocketPort uPCI SMPTE series uses Comtrol Application Specific Integrated
Circuit (ASIC) technology to replace most hardware functionality to minimize
components, including:
•

The processor

•

A serial controller

•

Bus interface logic and other miscellaneous logic

You can install up to four RocketPort uPCI SMPTE cards in one computer,
providing a maximum of 8 to 32 additional serial ports. The PC must comply with
the PCI 2.2 specification or greater.
The RocketPort uPCI SMPTE conforms to the ANSI/SMPTE 207M-1997
Television – Digital Control Interface – Electrical and Mechanical Characteristics
standard. The Society of Motion Picture and Television Engineers (SMPTE) 207M
protocol permits the control of video and audio tape decks for editing purposes and
can be used to connect controlled device such as, video routers and servers.

Supported Models
The RocketPort uPCI SMPTE family provides DB9 female SMPTE 207M
connectors that can be connected to devices with Sony DB9 connectors and
consists of the following models:
•

2-Port model with the connectors on the edge of the card

•

8-Port model with the following interface options:
-

Octacable (fanout cable) with eight connectors
Panel interface box with eight connectors
Rack Mount interface box with eight connectors

Before Installing the RocketPort uPCI SMPTE
If you are planning on installing the RocketPort uPCI SMPTE in a Windows
system make sure that you have placed the device driver assembly to a location
that is available to the host system before installing the card in the host.
You can use the Software and Documentation CD to locate the latest device drivers
and documentation. Optionally, you can use the links in the following subsection.
You may want to record the model and serial number of the RocketPort uPCI
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SMPTE before installing the card in the event you need to call technical support.

Locating the Latest Drivers and Documentation
This table contains links the software and installation documentation.
Software or
Document
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Location

Device drivers

ftp://ftp.comtrol.com/html/RPuPCIsmpte_drivers.htm

Diagnostic and
Utilities

ftp://ftp.comtrol.com/html/RPuPCIsmpte_diag.htm

User Guides

ftp://ftp.comtrol.com/html/RPuPCIsmpte_docs.htm
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This section discusses the following:
•

Installing the Card

•

Attaching an Octacable Interface Cable on Page 8

•

Attaching a Panel Interface Box on Page 9

•

Installing a Rackmount Interface Box on Page 10

Installing the Card
Use the following procedure to install a RocketPort uPCI SMPTE card.
1. If this is a Windows installation, copy the latest driver to your system before
installing the RocketPort uPCI SMPTE. See Locating the Latest Drivers and
Documentation on Page 6 to locate the latest driver and installation
documentation.
2. Turn off the host computer.
Note: You may want to write down the model number and serial number of
the card before installation.
3. If necessary, set the DIP switches for the appropriate communications mode.
The default DIP switch setting on the 8-port is DTE (pictured below) and the
default DIP switch setting on the 2-port is DCE (light blue DIP switch).
DIP Switch

•

DCE mode, if necessary, set the DIP switch to ON on the corresponding
ports.

•

DTE mode, if necessary, set the DIP switch to OFF on the corresponding
ports.
8-Port Factory Default Setting = DTE
OFF
ON

DCE = On (Down)
DTE = Off (Up)
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2-Port Factory Default Setting = DCE
OFF
ON

1 2
DCE = On (Down)
DTE = Off (Up)
4. Remove the system cover from your computer.
5. Select a PCI expansion slot.
6. Remove the slot cover or release the clamp.
7. Insert the card into the slot and seat it securely.
8. Reinstall the expansion slot retaining screw or clamp.
Note: You may want to replace the system cover after the driver is installed
and running in the event that you need to change the DTE/DCE switch
setting.
Do not connect an interface to the card when the host system is
powered on, this can cause card failure.
Caution

9. Attach the interface or cable to the RocketPort uPCI SMPTE:
•

Attaching an Octacable Interface Cable on Page 8 (below)

•

Attaching a Panel Interface Box on Page 9

•

Installing a Rackmount Interface Box on Page 10

•

If this is a 2-port installation, see Connecting RS-422 Serial Devices on
Page 11 for cabling information after driver installation.

Attaching an Octacable Interface Cable
Use this procedure to complete the octacable installation.
1. Make sure that the host system is powered off before connecting the cable.
2. Attach the DB78 end of the octacable to the card.
Make sure that the connectors are properly
aligned and forcefully push the connector of
the Octacable with a rocking motion into the
card connector. Make sure that the connector
is seated tightly before tightening the
retaining screws on the connector.

Caution

Octacable
DB9

3. Tighten the retaining screws on the connector.
4. Power on the host system.
5. Click Cancel if a Found New Hardware message
appears on a Windows operating system.
Execute the device driver file to start the driver installation.
For other operating system device drivers, see Locating the Latest Drivers and
Documentation on Page 6.
6. After installing the driver, you should verify that the ports are functioning
properly and then connect your serial devices.
You can use the Troubleshooting section on Page 15 for port testing procedures
for your operating system.
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Refer to Connecting RS-422 Serial Devices on Page 11 for information about
connecting serial devices.

Attaching a Panel Interface Box
Use this procedure to complete the installation with a panel interface box.
Do not connect the cable to the RocketPort uPCI SMPTE card or
interface box when the computer is powered on.
Caution

Connecting the cable to the RocketPort uPCI SMPTE card or interface
box while the computer is powered on may damage the electronics on
the card or interface box.
1. Make sure that the host system is powered off before
connecting the cable.
2. Attach the DB78 interface cable to the RocketPort uPCI
SMPTE card.

Make sure that the connectors are properly aligned. Do NOT use force
when connecting the cables to the host adapter card.
Caution

3. Tighten the retaining screws on the connector.
4. Power on the host system.
5. Click Cancel if a Found New Hardware message appears on a Windows
operating system.
Execute the device driver file to start the driver installation.
For other operating system device drivers, see Locating the Latest Drivers and
Documentation on Page 6.
6. After installing the driver, you should verify that the ports are functioning
properly and then connect your serial devices.
You can use the Troubleshooting section on Page 15 for port testing procedures
for your operating system.
Refer to Connecting RS-422 Serial Devices on Page 11 for information about
connecting serial devices.
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Installing a Rackmount Interface Box
Rackmount interface boxes are sturdy enough to allow you to stack several units
on a shelf, or you can mount it directly into a rack.
Do not connect the cable to the RocketPort uPCI SMPTE card or
interface box when the computer is powered on.
Caution

Connecting the cable to the RocketPort uPCI SMPTE card or interface
box while the computer is powered on may damage the electronics on
the card or interface box.
1. Make sure that the host system is powered off before connecting the cable.
2. Place the Rackmount interface box on a stable surface or attach the brackets
to the interface box using the screws supplied with the unit and attach the
bracket into your rack.
3. Attach the cable between the interface box and the card.

Make sure that the connectors are properly aligned. Do NOT use force
when connecting the cables to the host adapter card.
Caution

4. Power on the host system.
5. Click Cancel if a Found New Hardware message appears on a Windows
operating system. Execute the device driver file to start the driver installation.
For other operating system device drivers, see Locating the Latest Drivers and
Documentation on Page 6.
6. After installing the driver, you should verify that the ports are functioning
properly and then connect your serial devices.
You can use the Troubleshooting section on Page 15 for port testing procedures
for your operating system.
Refer to Connecting RS-422 Serial Devices on Page 11 for information about
connecting serial devices.
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This section provides information about the RocketPort uPCI SMPTE connectors,
in the event that you need to build cables or loopback plugs.
A loopback plug is a serial port plug with pins wired together that you can use
with application (for example, the diagnostic, Test Terminal, or minicom) to test
serial ports. See Before Calling Technical Support on Page 15 for information
about using the test application shipped with the RocketPort uPCI SMPTE.

DTE Versus DCE
The DIP switch for the RocketPort uPCI SMPTE ports are set to DTE at the
factory.
The RocketPort uPCI SMPTE conforms to the ANSI/SMPTE 207M-1997
Television – Digital Control Interface – Electrical and Mechanical Characteristics
standard. The Society of Motion Picture and Television Engineers (SMPTE) 207M
protocol permits the control of video and audio tape decks for editing purposes and
can be used to connect controlled device such as, video routers and servers.
Note: To connect the RocketPort uPCI SMPTE to SMPTE devices using SMPTE
cables, set the DIP switches to DCE for the corresponding ports. DTE and
DCE modes are controlled with the DIP switch on the RocketPort uPCI
SMPTE (see Card and Interface Installation on Page 7 for information).

DB9 Serial Cables and Loopback Plugs
The following figures and table illustrate the signals present on DB9 connectors if
you need to build your own null-modem or straight-through DB9 serial cables.
The RocketPort uPCI SMPTE provides female DB9 SMPTE port connections that
comply with the SMPTE 207M standard so that you can easily connect Sony DB9
devices.
•

DB9 Signals (RS-422) on Page 12

•

Straight-Through Cables (DCE) on Page 12

•

Null-Modem Cables (DTE) on Page 12

•

DB9 Loopback Plugs on Page 13
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DB9 Signals (RS422)

This subsection provides DB9 signal information. Refer
to the manufacturer’s installation documentation if you
need help with the connector pinouts or cabling for the
serial device.
SMPTE 207M DB9 Female Connector
Pins
1

DCE Mode
(SMPTE)

Pin 1

Pin 9

Pin 6

DTE Mode

Chassis Ground Chassis Ground

2

RxD-

TxD-

3

TxD+

RxD+

4-6

Not used

Not used

7

RxD+

TxD+

8

TxD-

RxD-

9

Female
Pin 5

Chassis Ground Chassis Ground

Note: DTE and DCE mode are controlled with the DIP switch on the RocketPort
uPCI SMPTE. See Card and Interface Installation on Page 7 for
information. The factory default is set to DTE. Set the DIP switches to ON
(up) for DCE mode.
Straight-Through
Cables (DCE)

Use the following figure if you need to build an RS-422 straight-through cable for
DCE devices.
RocketPort DCE Mode
Signal
TxD+
TxDRxD+
RxD-

Null-Modem Cables
(DTE)

Sony DB9 Connector
Pins
3
8
7
2

Pins
3
8
7
2

Signal
TxD+
TxDRxD+
RxD-

Use the following figure if you need to build an RS-422 null-modem cable for DTE
devices.
RocketPort DTE Mode
Signal
TxD+
TxDRxD+
RxD-

Pins
7
2
3
8

DTE Serial Device
Signal
RxD+
RxDTxD+
TxD-

Note: RS-422 signals are not standardized and each serial manufacturer uses
different pinouts. Refer to the serial device documentation to determine the
pinouts for the signals above.
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DB9 Loopback Plugs

RocketPort uPCI SMPTE are shipped with a a single loopback plug. You can use
loopback plugs with application software (for example, Test Terminal) to test
serial ports.
Wire the following pins together to build additional plugs or replace a missing
loopback plug.
•

Pins 2 to 8

•

Pins 3 to 7

RS-422 (Back View)

Note: DTE and DCE mode are controlled with the DIP
switch on the RocketPort uPCI SMPTE. See Card
and Interface Installation on Page 7 for information.
The factory default is set to DTE. Set the DIP
switches to ON (up) for DCE mode.
Straight-Through
Cables (DCE)

Pin 1

Pin 9

Pin 6

SMPTE Loopback

Use the following figure if you need to build an RS-422 straight-through cable for
DCE devices.
RocketPort DCE Mode
Signal
TxD+
TxDRxD+
RxD-

Null-Modem Cables
(DTE)

Pin 5

Sony DB9 Connector
Pins
3
8
7
2

Pins
3
8
7
2

Signal
TxD+
TxDRxD+
RxD-

Use the following figure if you need to build an RS-422 null-modem cable for DTE
devices.
RocketPort DTE Mode
Signal
TxD+
TxDRxD+
RxD-

Pins
7
2
3
8

DTE Serial Device
Signal
RxD+
RxDTxD+
TxD-

Note: RS-422 signals are not standardized and each serial manufacturer uses
different pinouts. Refer to the serial device documentation to determine the
pinouts for the signals above.
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If you are experiencing problems with the RocketPort uPCI SMPTE, review the
troubleshooting procedures for your system before calling Technical Support.

Before Calling Technical Support
Review the following information before calling Technical Support because they
will request that you perform many of the procedures or verifications before they
will be able to help you diagnose a problem.
•

Verify the cabling using Connecting RS-422 Serial Devices on Page 11.
Note: Most customer problems reported to Comtrol Technical Support are
eventually traced to cabling or network problems.

•

If you have not done so, run the diagnostics (RocketPort uPCI SMPTE
Diagnostics on Page 15).

•

Verify that you have installed the latest RocketPort uPCI SMPTE device
driver, see Locating the Latest Drivers and Documentation on Page 6.
If necessary, remove or update the existing driver using the procedures in the
RocketPort uPCI SMPTE Device Driver Installation Guide for Windows or
README file packaged with the FreeBSD, Linux, QNX, or SCO OpenServer
driver.

If none of the above work, you can refer to one of these subsections:
•

Troubleshooting Windows Systems on Page 17

•

Troubleshooting Linux Systems on Page 25

RocketPort uPCI SMPTE Diagnostics
This subsection describes how to create and run the bootable diagnostic to verify
that the RocketPort uPCI SMPTE hardware is functioning properly. The
RocketPort uPCI SMPTE is shipped with a bootable diagnostic on the Software
and Documentation CD that executes hardware diagnostics.
You can use the diagnostic to:
•

Confirm that the hardware is functioning

•

Determine resolutions to conflicts during installation

•

Perform a stress test on all RocketPort uPCI SMPTE ports in the system

The diagnostic requires a loopback plug to test a port or ports. A single loopback
plug is shipped with the RocketPort uPCI SMPTE. You can build additional
loopback plugs or move the loopback plug to the port you want to test. See
Connecting RS-422 Serial Devices on Page 11 if you want to build loopback plugs.
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Bootable CD

Use the following procedure to create a bootable Diagnostic CD.
1. Copy the .iso file to a temporary location.
The diagnostic .iso file can be copied from the Software and Documentation
CD or you can download the latest version (Locating the Latest Drivers and
Documentation on Page 6).
2. Burn the image to a CD-ROM.
Note: An .iso file cannot be copied onto a CD but must be burned using an
application that burns the image to the CD. If you do not have an
application available, you can use a freeware application that is on the
Comtrol Software and Documentation CD or download it at: ftp://
ftp.comtrol.com/iso/IsoBurner/.
3. To run the diagnostic, you will need at least one loopback plug. A loopback
plug was shipped with the RocketPort uPCI SMPTE. To build a loopback plug,
see DB9 Loopback Plugs on Page 13.
4. To start the diagnostic, reboot your system with the Diagnostics CD in the
drive and follow the instructions in the diagnostic.

Running the
Bootable Diagnostic
CD

Use the following procedure to run the diagnostics.
Note: If the diagnostic goes into sleep mode while unattended, press the Num Lock
key to activate the screen. Use Ctrl/Alt Delete to kill the diagnostic process at
any time.
1. Insert the bootable CD that contains the diagnostic and restart your machine.
Note: If the Diagnostic CD does not boot the PC, you may need to change your
BIOS settings so that the PC can boot from a CD drive.
The diagnostic starts automatically and takes a few moments before the first
screen appears.
Note: If the diagnostics did not detect the RocketPort uPCI SMPTE, the
adapter has a hardware failure, contact Technical support (Page 26).
2. Press Any Key at the disclaimer screen to begin the diagnostic.
3. Press Any Key at the Please Note screen about RocketPort ISA.
4. Press Enter to Are there ISA boards installed? in the VERIFY TEST screen.
5. Press Enter to the Is this board configured for RS-422? query.
Note: The caution at the bottom of the screen that the RS-232 test will fail
when run on an RS-422 port.
6. Press Enter to the Is this board configured for RJ45 cables? qquery.
7. Select from the following options and use the appropriate steps:

Testing a Port or
Ports

•

Testing a Port or Ports

•

Stress Testing the RocketPort uPCI SMPTE

8. Enter 1 to 4 and press Enter to test a port or ports on a specific RocketPort
uPCI SMPTE or on multiple adapters.
9. Press Enter to test ALL ports on the RocketPort uPCI SMPTE or enter the port
number of a port that you want to test.
10. Follow the instructions on the screen. If you are testing all of the ports and
have only one loopback plug, you must move it from port to port during the
test.
Note: Port 0 in the diagnostic is Port 1 on the octacable or interfaces.
The diagnostic will provide hardware status on the TESTING SERIAL I/O,
MODEM CONTROL AND IRQ screen. The Modem Control tests correctly
display N/A (because there are no modem control signals in RS-422 mode).
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11. Choose from the following options:

Stress Testing the
RocketPort uPCI
SMPTE

•

Press Q to quit the diagnostic without reviewing the Test Summary screen.

•

Press R to return to the board test screen.

•

Press any key or Enter to review the Test Summary screen, which provides
the ability to restart (Y) or quit (N) the diagnostic.

Select S and press Enter to access the STRESS TEST screen. Make sure that you
have a loopback plug installed on each port on each adapter.
The stress test uses a default configuration to simultaneously stream data to all
ports of the RocketPort uPCI SMPTE cards in a system until you stop the test.
The following options are available:
•

To stop the test and review the results of the stress test, enter S.

•

To return to the board test screen, press R.

Exiting the
Diagnostic

To end the diagnostic, you may need to select b to return to a screen that contains
a q to quit. Type reboot, select Enter, and remove the CD from the drive when
prompted.

If the Diagnostic
Fails

If the diagnostic fails, try the following before contacting Technical Support.
1. Turn off the power and reseat the RocketPort uPCI SMPTE card into the slot.
2. Try running the diagnostics again. If they fail again, you may have a bad port,
contact Technical Support on Page 26.

Troubleshooting Windows Systems
If you are using a RocketPort uPCI SMPTE driver on a Windows system and the
diagnostic verified that the card is functional, you can check the following:
1. Verify that the RocketPort uPCI SMPTE has installed by checking the Device
Manager to verify that the RocketPort uPCI SMPTE card displays.
2. Verify that you are addressing the port correctly.
In many applications, device names above COM9 require the prefix \\.\ in
order to be recognized. For example, to reference COM20, use \\.\COM20 as
the file or port name.RocketPort uPCI SMPTE.
3. After driver installation, if a port does not open; go to Ports COM & LPT, rightclick on the yellow exclamation mark on the port, and click Update Driver. Use
the same procedure used when installing the ports that are detected with plug
and play systems.
4. Enable the Verbose Event Log feature on the Options tab of the RocketPort uPCI
SMPTE driver and then reboot the server.
5. Install and use one of the tools in the Comtrol Utility package. Use the
following subsection, Comtrol Utility, below for installation and adapter
testing procedures.
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Comtrol Utility

The Comtrol Utility is available on the Software and Documentation CD or you
can download (Page 6) the latest version. The file is a self-extracting zip file that
automatically starts the installation procedure. It is not necessary to reboot the
PC after installation.
The Comtrol Utility package includes the following applications that you can access
from the Comtrol Program group:
•

Port Monitor (PortMon2) checks for errors, modem control, and status signals.
In addition, it provides you with raw byte input, output counts, and confirm
that the device driver is functioning. It can determine if the ports are in use by
another application.

•

Test Terminal (WCOM2) can be used to troubleshoot communications on a portby-port basis (Using Test Terminal to Test a Port on Page 23). Test Terminal
requires a loopback plug. You can build a loopback plug if you are missing the
loopback plug shipped with the adapter (Connecting RS-422 Serial Devices on
Page 11).

Use the following
procedure to install the
Comtrol Utility package.
1. Execute the
Comtrol_Utility_Pack
age_x.xx.msi file,
where x_xx is the
Comtrol Utility
version number.
2. Click Next.

3. Click Next.
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4. Click Install.

5. Click Finish.

6. Go to Using PortMon to Test the Driver Installation on Page 20.
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Using PortMon to
Test the Driver
Installation

You can use PortMon to check whether the RocketPort uPCI SMPTE can
communicate through the device driver for Windows. If necessary, use Comtrol
Utility on Page 18 to install PortMon.
1. From the Start menu, select Programs > Comtrol > Utilities > Port Monitor
(PortMon2).

2. Click Add Ports using the icon or Tools > Add Ports, click Driver, ROCKETPORT,
and click Ok.
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3. If the RocketPort uPCI SMPTE is communicating with the device driver for
Windows, Port Monitor should display CLOSED status. If a port is open for an
application, it displays as OPEN, and displays Actual Throughput, TxTotal and
RxTotal statistics.

Normally, there should be no data errors recorded or they should be very
small. To find out what the actual errors are, scroll to the right. You will see
three columns: Overrun Errors, Framing Errors, and Parity Errors.
If the errors are:
•

Overrun Errors represent receive buffer overflow errors. If this is the case,
you will have to configure either software or hardware handshaking to
control the flow of data. The most common errors are Overrun errors.

•

Framing Errors indicate that there is an synchronization error between the
beginning of a data frame and the end of the data frame. A frame usually
consists of a start bit, 8 data bits, and a stop bit or two. The framing error
occurs if the stop bit is not detected or it occurs in the wrong time frame.
Most causes for framing errors are electrical noise on the data lines, or
differences in the data clocks of the RocketPort uPCI SMPTE and the
connected device.

•

Parity Errors occur when parity is used and the parity bit is not what is
expected. This can also be caused by noise on the data lines.

4. You can view additional statistics to Port Monitor by adding columns. Click
Tools and Add Columns.
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5. Highlight or shift-click to add multiple statistics and click Ok.

Note: See the Port Monitor help system if you need an explanation of a
column.
6. Scroll to the right to view the new columns.

7. If you want to capture this session, you can save a current session as a report.
To do this, select one of the following save options:
•

File > Save As

•

File > Save - if the report already exists in an older format

•

Save Active Session

button

Reports can be opened, viewed and re-used when needed. To open and view a
report:
a. Select File > Open or the Open Existing Session
Session dialog appears.

button. The Open

b. Locate the session (table), you want to open and click the Open button.
Optionally, if you want to continue monitoring for an existing session, you
need to activate the Polling Interval.
•

Select Tools > Settings to access the PMon2 Settings dialog

•

Change the Polling Interval field to a value other than zero (0)

8. Leave Port Monitor open so that you can review events when using Test
Terminal to test a port or ports.
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Using Test Terminal
to Test a Port

Test Terminal (WCom2) allows you to open a port, send characters and commands
to the port, and toggle the control signals. This application can be used to
troubleshoot communications on a port-by-port basis.
The Send and Receive Test Data sends data out the transmit line to the loopback
plug, which has the transmit and receive pins connected thus sending the data
back through the Rx line to Test Terminal, which then displays the received data in
the terminal window for that port. This test is only testing the Tx and Rx signal
lines and nothing else. A failure in this test will essentially prevent the port from
working in any manner.
The Loopback Test tests all of the modem control signals such as RTS, DTR, CTS,
DSR, DCD, and RI along with the Tx and Rx signals.
Note: This test will fail and is expected to fail since RS-422 does not have the
modem control signals that are present in RS-232 for which this test is
designed.
The following procedure shows how to use Test Terminal to send and receive test
data to the serial ports and run a loopback test. If necessary, install the Comtrol
Utility package using Comtrol Utility on Page 18.
1. Stop all applications that may be accessing the ports such as RRAS or any
faxing or production software. See the appropriate help systems or manuals
for instructions on stopping these services or applications.
If another application is controlling the port, then Test Terminal will be unable
to open the port and an error message will be shown.
2. From the Start menu, select Programs > Comtrol > Utilities > Test Terminal
(WCom2).

3. Select File > Open Port, the
appropriate port (or ports)
from the Open Ports drop list
and Ok.
Note: If you left Port Monitor
open from the previous
subsection, you should
show that the port is
open.
4. Install the loopback plug (DB9
Loopback Plugs on Page 13)
onto the port (or ports) that
you want to test.
5. Select Port > Send and Receive
Test Data.
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You should see the
alphabet scrolling
across the port. If so,
then the port installed
properly and is
operational.
Note: If you left Port
Monitor
running, it
should show
data sent and
received and
show the
average data
throughput on
the port.
6. Select Port > Send and
Receive Test Data to stop
the scrolling data.
7. Close Test Terminal.
If this test successfully completed, then the port is operational as expected.
Note: Do NOT forget to restart the communications application.
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Troubleshooting Linux Systems
You can use the following subsections to test the serial ports.
lcom(1)

Comtrol has available lcom(1), which is a multiport serial I/O test program. You
can use lcom in test mode to send test data to any serial port.
lcom is available on the Software and Documentation CD or you can download the
latest version.
Note: For assistance using lcom, use the manual page, lcom(1) that accompanies
the program.

File Transfer

You can transfer a file using the following information. The default settings are
9600, 8, n, 1, and no parity. To send a file you can redirect output to a device; for
example:
cat /etc/inittab > /dev/ttyR0

Sends the contents of the /etc/inittab file to the ttyR0 device at 9600 baud, 8, n, 1,
and no parity.
Changing Serial
Port Settings (stty)

Use the following information if you need assistance changing or viewing the baud
rate settings.
To change the baud rate, use the following example, which changes the baud rate
to 19200:
stty 19200 </dev/ttyR0

To view the current serial port settings for ttyR0, enter:
stty -a </dev/ttyR0

Note: Settings changes via stty are only valid during current log in session. For
permanent setting changes, use the /etc/inittab file.
Setting Up
Terminals and
Modems (mgetty,
getty)

Add the appropriate line or lines to the /etc/inittab file then restart.
Terminal Example:
T0:23:respawn:/sbin/agetty -L ttyR0 57600 vt100

Modem Example:
T1:23:respawn:+/sbin/mgetty -m ‘”” AT&F OK’ -D -x9 -s 115200 ttyR0

Note: If necessary, see the manual pages for more information on mgetty.
Testing with
minicom

You can also use minicom, which shipped with most Linux distributions, to test the
serial ports. A Comtrol document is available for using minicom.
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Technical Support
Comtrol has a staff of support technicians available to help you. You should review
Before Calling Technical Support on Page 15 before calling Technical Support. If
you call for Technical Support, please have the following information available:
•

Model number

•

Serial number

•

Interface type

•

Operating system type, release, and service package, and if Linux, the kernel
version

•

Device driver version

•

Computer make, model, speed, and single or dual processor

•

List other devices in the computer and their addresses
Contact Method

Corporate Headquarters

Support

http://www.comtrol.com/pub/en/Support

Web site

http://www.comtrol.com

Phone

763.494.4100

Downloads

ftp://ftp.comtrol.com/html/default.htm

Note: See Locating the Latest Drivers and Documentation on Page 6 for
additional links.
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